Problem with order of same-year same-author reference

Hello. My problem is quite specific. I have two references published by the same first author in the same year. My problem is that the order is wrong if you are looking at the month it was published in. I need the order to be reversed because the reference with the 2014b comes before the 2014a (both in terms of when i cite it as well as when it was actually published). The citation output format does it by Author, Year, Title. This is fine, however, Endnote doesn’t seem to recognize the difference in month of publication (even though when one looks at the reference details on Endnote [x7 Mac Version], it does say which month it was published in [the 2014b published in May, whereas the 2014a published in Dec]). I’ve tried editing the citation order formatfor the bibliography so that its a custom of Author, Year, Date, Title. However, this did not work. I did this change because i assumed that it was sorting the two papers i wanted to cite based on the first letter of the title (given that the 2014a title starts with ‘Localization’, and the 2014b starts with ‘Stress’).

So my question is how to adjust this order between the two papers without affecting other citations.

P.s. the referncing output is Orient Pharm Express, to which i have already edited one aspect about it (specifically the Citation sort order within the text of the paper: which is now Year + Author - not that that makes a difference anyway).



Could you attach your output style and why is “Date” included in the citation sort order “Author, Year, Date , Title”? If there’s data in the Date field within the two records that might be preempting sorting on Title.

Endnote is unable to sort months (within the Year field) unless it is in a numerical format. However, in your case the sort order of Author, Year, Title should yield the correct results given the difference in the 2014a and 2014b titles.So 1) change the citation sort order to Author, Year, Title (or change the setting to “same as bibliography”); 2) check the bibliography sort order to confirm it is not contradicting the citation sort order; and 3) update your citations and if they do not self-correct then convert the citations to temporary citations then update citations. If the problem continues, examine the Year and Title fields of the two records for extra spaces and correct or re-enter the info.

I have attached the output style. I only included the date in the sort order as a way to see if it would sort the two articles the way they should be sorted (i.e. respective of the month they were published in 2014). And as a side note, it doesnt do so. It is true that after sorting it by Author, Year, Title what ends up happening is that both 2014 articles by the same author are lumped together and become sorted based on the first letter of the title (as i mentioned; the first word for the 2014a article beginning with “Localizaiton” and the 2014b article beginning with “Stress”). And i know this because if i edit the title of the 2014b article to start with “Atress”, it turns into the 2014a. But now i have a case where the title of the article is incorrect.

So. My question is: How can i sort these two articles published by the same author, during the same year, but have the one published earlier (i.e. chronologically) appear as my 2014a citation.?

I have also attached the two articles so you can see what the problem looks like.

Thanks for your help and time. I appreciate it.

Orient Pharm Exp Med.ens (27.1 KB)

Thanks for the output style file. Here’s a workaround. What you could do is to keep the Year field in the bibliography templates but create a second Year field (“SortYear”) which would contain the year and month and be used to sort the bibliography. This would generate the bibliography where the two articles by the same author/during the same year would be in chronological order that accounts for year and month (and which overrides the alpha-order of the Title field). Refer to attached image #3 showing the result.

The workaround involves the following:

1a. Add a custom field (Custom 8, re-named as “SortYear”. (This field will be used to hold the year and month data in numerical format.) (Refer to image #1.

  b. Use the Change/Move/Copy Fields function to copy the data in the Year field for all of the records into the Custom 8 field. (Refer to image #1.)

  c. Change the bibliography Sort Order to: Author + Custom 8+ Title. (Refer to image #1.)

2, For the two records having the same author, enter the year and month in numerical format in the “SortYear” field. So for example, the article which was published in May will have 201405 in the SortYear field. The article which was published in December will have 201412 in the SortYear field. (Refer to image #2.)

The resulting bibliography is shown in image #3.

Thank you very much for your help. It worked. Neat trick.