The dreaded corrupt library: This library is being used by someone else. Try opening it again later.

I’ve read through various previous threads on this subject but now I’m totally stumped as to what to do.

 I’m on a Mac (using Endnote 8.2) - can’t open any libraries, I’ve tried recovering the library onto my local drive to make sure it’s not a network problem (that didn’t work), I’ve tried rebooting and also uninstalling/reinstalling Endnote - still the same error: This Library is being used by someone else. Try opening it again later.

Please can someone at Endnote help - some of us have assignments to finish and deadlines to meet and this is taking up way too much time when I should be working on “proper” stuff.

Please contact Technical Support directly

1-800-336-4474 option 4 then 1


We are here to help whenever you run into issues.

Thank you - I phone Technical Support and they were able to help me. 

As I had synchronised my library into the cloud, I was able to create a new library locally on my machine and synchronise it with the cloud - all of my library has been fully recovered and restored.

Thank you to the Tech Support team.

hey, thanks for the solution … i was having the same issue.

best regards!!!