X3 could not format as [1,2] but [1-2] in numbered style?

When I insert two successive references  such as 1 and 2, X3 could not format as [1,2] but [1-2]  in numbered style, and I need a comma instead of a hyphen between the successive references, X2 can do this. Is it a bug of X3? Any suggestion? Thank you!

Can you check:

Edit>Output styles>Edit “your style”>Citations>Numbering> Use ranges for consecutive citation

Change this option checked or unchecked, and see the results?

Thanks myoshigi!
When I uncheck this, [1-2] did change to [1,2], but some other unexpected results occured, the original corrected result [3-8] became [3, 4, 5, 6, 7, 8], how can I obtain [1,2] and [3-8] simultaneously?

This problem has’t not been solved, I click the wrong hyperlin.

I checked the style options, but I don’t think EN X3 can do that. I can’t remember X2 was able to do that, wasn’t it?

To be honest, I’ve never paid attention to this until you pointed out. I just thought 1-2 was just fine. If it’s not, probably publishing editors have taken care of? I usually submit manuscript with a bibliography just endnote can do, and wait until publisher says something, after it is accepted. Until then, even I notice small differences between authors instructions and endnote format, I just ignore them because the manuscript has to be accepted first. I know saying this to you doesn’t solve your problem, but EN has stopped me writing when I was paying too much attention to the details of bibliography formatting.

In fact, in En x2, I can format the bibliography like [1,2] and [3-8] but x3 can’t.

Thank you anyway


We’ve recognized that this is a bug in X3. We’ve already fixed it for the upcoming Mac release, and it will be included in the next patch that we release for Windows soon.

We’re very sorry for any inconvenience that it might cause in the meantime.

-The EndNote Team