Author's initials and space before :

I am currently on Endnote 9 and am creating a new style for a journal.
The author’s names must appear like Smith AB (no dot, no space for the initials). Unfortunately, and whatever the option I try, the initials appear like Ab.
Secondly, I need a no-break space before : (because the journal is in French) and EndNote refuses absolutely to insert this space.
I have already noticed these 2 facts several times and the solution was to correct the bibliography once created. But this time I would like to provide this style to the editor of the journal, so I need something perfect.
Thank you for your suggestions,

Isabelle Michot
Documentaliste / Information Officer
OFDT - Observatoire Français des Drogues et des Toxicomanies
[French Monitoring Centre for Drugs and Drug Addiction]
3 avenue du Stade de France

The problem with Author Initials is solved by the record entry.  You need a space between the initals there, or else Endnote interprets them as a name and not as initials.  Then in the style you can specify the option you prefer from the Bibliography, Author Name Initials dropdown list. 

I am afraid I have found no way to insert a non-breaking space in Endnote.  For the time being, perhaps you could suggest that the French journal publisher  apply a quick processing step to see if it isn’t there and insert it for their authors.  Submitting a request for non-breaking spaces, hyphens and dashes might also be warranted, as it has come up before in the forum.   

Yes, I have thought about the initials in the record entry but they are all entered like A. B. so there is a space.

Thank you for your help.

Can you attach your current style please?

Here is it (Psychotropes.ens).

Psychotropes.ens (9.19 KB)

The problem seems to be that the Capitalization: settings for Author lists is set as Normal, rather than As Is. 

I wouldn’t have expected it to function in this way, but it does convert the AB to Ab. 

This is obviously a bug, and should be reported to Thomson!  I could see were one might want to convert the authors which were entered from some database in all caps, to “sentence” format, but would certain never want that setting to apply to the the initials. 

I have just checked and the same bug occurs in both X2 and X3.

1 Like

Hi!  Have you tried setting the Author Name Capitalization to “As Is”?

Thank you for your suggestion but it doesn’t work because some authors’ names are entered in capitals and others not.

I will use the initials setting A B instead of AB. I have not other choice.

Thank you for this check. Maybe the impossibility to insert a space before : is also a bug.

Probably more of a pesky “English” rule applied indiscriminately.  I have passed on the first bug and will pass on your concerns with the space. 

Yes, that’s what I have thought.

Thank you for passing on those bugs.

Best regards