Can't edit references

Hi, I’m in Endnote X7, Mac. No matter what I do, double-click a refernece, right-cllick and select EDIT REFERENCE all that happens is that the PDF opens up. Is there some setting I have to change? Before, double-clicking a refeence always opened the reference, not the pDF.



It sounds like the layout has been changed so that you can’t see all the parts.  Have you tried changing the layout?  on a PC the layout options are in the lower right hand corner of the open record window. 

I have just recently purchased a mac and installed endnote and am having the exact same problem.  It is not layout dependent - I was able to edit one reference before it just stopped working.  Now when I click on an existing reference to edit, it allows me to highlight what is in the field, but will not delete, will not accept text, will not do anything.

Desperately seeking help!


This sounds more like you might have a record window open in the background  - behind your main library. If this is the case, it is by design that you could not edit in the main library window - to avoid making changes to the same data from two different windows.

To check this, you can use the “Window” menu to see how many items you have open. See the attached screen shot where I have a record “GHAOUI, 1997 #3946” open along with my main library. If I close it, then I can  edit in my main library window.

I hope this helps.

Jason Rollins, the EndNote team

Thank you - I believe that was it!  


I cannot edit saved references in EndNote Web. I can create new references but when I then return to them I cannot change any of the fields as none of them open to allow editing.

HOWEVER - this only happens on my main desktop PC. When I went into EndNote Web on my Netbook I was able to edit as normal.

I have also trued to create an alternate new User Account on my desktop and this made no difference.

I’m having this problem as well.  It was happening in X6 and I found that opening/closing the program helped.  Just upgraded to X7 and now nothing works.  I don’t have any open windows.  How do I edit a reference if only the PDF opens?

I find that if I create a new reference that I will then be able to open existing reference records.  This is clearly a bug that needs to be addressed.  I hope it does not continue to occur.

Thank you! That has solved the problem I was having too. I find the new x7 very counter intuitive though in terms of viewing references, editing and opening pdfs. I hope they make it easier with an update. Cheers

I have the same problem reported by the previous posters.  I’m unable to edit a reference - double clicking on it or clicking on “edit references” only opens the pdf.  This occurs when no other windows in Endnote are open.  The trick suggested by a previous poster, to first open a new reference, also works for me.  I’m running Endnote 7.0.1 under Mac OS10.9.2

Not sure I am following this issue correctly, but, I hope the attached screen shot might help. If not, please let me know. Regardless, I agree that this workflow could likely be improved and will have the team look into it.

Jason Rollins, the EndNote team

This addressed the issue, though it was surprisingly difficult to figure this out. Thanks for your help!

This may depend upon the kind of PDF that is attached in the Library.

I have an old PDF that is more jpeg-like, and, after several iterations of the advice given here, switched to a different–more recent–PDF reference: Worked first time.

Any suggestions or work-arounds for the older PDF’s? Even trying to draw boxes did not work.