Window for editing references does not open in Endnote 20

Just updatet to Endnote 20 but have problems editing references. I try to dobbel-click a reference and the screen just blinks but the edit window does not open. Have also tried to right click the reference and select “Edit reference” but the same think happends. Have tried to restart Endnote but the problem still persists. 

#Edit: Creating new reference works, and opens in a new windos. 

#One more Edit: What appears to happend is that when i double click a reference a new window with the reference list opens…

Windows 10, Endnote 20. 

One update to this. It appears that in Endnote 20 the “Edit funciton” opens in a seperate window to the right of the reference list. This was also possible in the earlier versions. But some of the edit functions are missing. in particular, I really miss the buttons to change to lower case. This is very usefull since a lot of title of references are imported either in all uppercase or with the first letter in each word as uppercase. 

Are there somwhere I can get this back in the edit window?


I’m having the exact same issue rendering Endnote…useless. Is there a fix for this?

I too am very frustrated by the apparent inability to double click on a reference and have a new window with that reference open up. Having it appear on the side is really problematic for the way I have been accustomed to using EN these past 10 years. Is there a way that I can downgrade to an earlier version that I have purchased that still has this functionality? It is that important to me that I would love to be able to do that.