Can't get X3 to read my tagged text import files correctly.

I am using X3 on a MacBook Pro running OS 10.5.8. I am trying to set up tagged text files to important references.The results have been unpredictable and frustrating.

From X3 Help, I have read carefully the instructions for preparing such files. I have tried using both Mac TextEdit and MS Word for creating these files, in each case saving the file in the recommended text encoding and using the corresponding input filter. For input options I have used I have used both Refer/BiblX and EndNote Import. As input filters I have used both that of the text encoding with which I have saved the particular file and have also tried No Translation. And I have tried practically every combination of the above.

I tried both single and multiple reference entries. I have obtained four categories of results, listed here in order of result frequency (highest first):

  1. Using input file with a single reference item, I obtain  a single reference record with all fields correctly assigned except the reference type, which always turns out as Generic even though my source item is tagged “Book.”

  2. Using multiple reference items (each separated by a blank line) in the input file, I obtain a single reference record with the titles mashed together in the order they appear in the input file list, as well as mashed entries in the other fields. Again, the reference type assigned is Generic.

  3. Occasionally I would get no import action at all … presumably when I had the text encoding type mismatched to the input filter.

  4. On one occasion, using multiple reference entries for input, I obtained TWO records. I wasn’t able to repeat what I did so I’m not sure of all the result details, except that the first of the two records had the first input item title and the second had the last input item title.

In sum, I am quite puzzled by these seemingly unpredictable results, with no result completely correct. I am attaching a copy of a (three item) tagged input file below.
Untitled 2.txt (402 Bytes)

@chonacky wrote:


 1. Using input file with a single reference item, I obtain  a single reference record with all fields correctly assigned except the reference type, which always turns out as Generic even though my source item is tagged “Book.”




Sounds like the “Reference Type” setting within the import file might be set to Generic but needs to be changed to Book. 


  1. Check the import filter’s setting by going to the EndNote toolbar, select EDIT, IMPORT FILTERS, then name of the filter - I’ll use Academic Search Elite (EBSCO) for this example.


  1. Within the filter’s display window (see attached), click to select “Reference Type”. Then click the Default Reference Type pull-down menu to change the default to “Book”.


  1. Also check that there’s a corresponding Book template available.  (Click the “Templates” option above Author Parsing.) If none is present, you’ll need to make one but it seems you can do so by replicating the tags and fields from the current template.


  1. When you’re done, close the window and save the changes to the filter.


As for the items #2-4 in your description, could you could attach the filter and a sample .txt file, especially the one which produces the duplicate record.




First, my problem with assignment of everything to ‘Generic’ reference type is now solved once I discovered that the correct tag was “%(zero)” and not “%(capital o).” In fact, the EndNote X3 Help that describes tagged input files (incorrectly) states that each tag is “% followed by a single capital letter.” I had noted that in fact the table of tags on that Help page clearly contradicted this by indication tags that were numbers as well as punctuation characters, etc. but the “penny did not drop.” I think that this ought to be corrected since the naieve user (e.g. me) will not notice this immediately.

More significantly for me, the modification of this tag not only clears up that first mystery, but it also seems to have solved the problem of  data concatenated from individual input item bening entered in a single record. Since I need to work on my paper after spending (too) much time trying to figure out how to tame EndNote, at this point I am going to settle for “if it isn’t broke, don’t fix it”!

On the other hand, your note responding to my plaints was very useful in other ways. Most particularly, it lead me to discover how to edit the input filters and also to provide templates for those input items that were not being parsed properly (e.g. Conference papers template was completely undefined). So I owe you a great deal of thanks and am grateful that you responded so quickly.

I don’t know how many people realize that EndNote has a rather steep learning curve - I didn’t. Even for someone like me who is physicist and quite computer literate, I was stumbling around for hours trying to make these tagged import files because I recognized that they were the route to reduce the time for the most labor-intensive step in using EndNote - data entry.

Thanks again – Norman

I have just one more (really a complaint) comment about the parsing of tagged source files for input of reference items:

I just discovered why a recent “recidivistic” ploy on the part of EndNote has caused me an excessive amount of grief and time to uncover it. It used to be that I was able to import “journal article” types, startng with the default (furnished) version of the Refer/BiblX, with some success. In trying to reconfigure this template to remove certain translation errors, I indavertently spoiled the proper import of the Journal Name parameter. Instead of the specified (and properly tagged - to be safe, with both %J and %B) journal name, the Journal field inserted into the record turned out to be literally “Journal Name.”

My investigation of why led me to try some other filters with their templates. I turned to “ACM” as a source, and found that it was able to correctly parse my tagged ("%B and/or %J) source file for the journal name item. But trying to use a replicate of this template within my Refer/BiblX filter failed in the manner just described above. I was only able to resolve this issue by (chance) going to the “source parsing” page of the default ACM filter and compared the same page to my revised Refer/BiblX filter. What I discovered was that the ACM template used “{None}” for “Journal Article Source tag,” while mine was configured to use “%J”. It turns out that changing this parameter on my Source Parsing page removed this systematic error with reference item input from my tagged source file for the “Journal” name field.

My point is this … I don’t know whether mine was the “correction” to the (default) Refer/BiblX filter was the right thing to do. Bukt it now seems to work. My question to EndNote is, why did I need to work so hare to reconfigure the default environment in order to make my (rather mundane) use of EndNote as a database for my  references so difficult to rectify?