Problem of importing

I just upgraded to X4 and encountered a serious problem when I imported references from a text file.

First of all, I’ve done this for dozens of time with X1-X3 (either under Mac OS 10.5 or 10.6) and they worked fine.

System details: Mac OS 10.6, EndNote X4.

The importing procedures:

  1. I key-in the needed data to an Excel file and then save it as a text file.

  2. After some index codes added (such as notes about the reference type and field names).

  3. Import it from X4.

The problem was: some of them, and I failed to sort out its pattern, would miss the data of the Title field. It happened very often. No matter how many times I tried, it happened to the same references. 

Can someone help me out?

Thanks a lot.

I think I’ve got the answer.

If I copy the data and past them into a blank text file, everything just fine.

If I transfer the original excel file (created with MS Excel 2008 for Mac) into a text file, it cannot work correctly.

It seems that the MS Excel 2008 doesn’t work happily together with X4?

Yes, an excel file is not a “text file”, so I wouldn’t be surprised if it wasn’t interpreted and importable by Endnote.