Can't open recovered library

I received the error message “Database error.  Please verify that no other user has this library open simultaneously with write access.  If this error persists after restarting EndNote, then the library may be damaged.  To repair it please use “Recover Library” command on the Tools menu.”

I followed these instructions.  I received the message “0 references were recovered into the new library…”

When I then tried to open the new library, I got the message “The file is not a valid EndNote library or has been created by an incompatible version of EndNote.”

Can anyone explain what is going on and tell me what I might do to fix this?

I am using EndNote X2 running under Windows XP.


Did you move the library before you got that error message?

The drive on which the library resides was moved about a month ago, but the problem only arose a few days ago.

Not sure then. No one messed around with a .DATA folder of the same name?  Did they back up things a month ago,  or do you have a recent backup (our IT routinely allows us to retrieve backups from each day, back about a week). 

If no recent backup, does the recovered library have a new name, so the original file and .DATA folder and contents have not been overwritten?

I did indeed name the recovered library with a new name, so that I still have access to the old library.  I have tried recovering that same library 2 more times (naming each with different names).  In all cases, I run into the same problem.

I can probably find older versions of the EndNote library via my back-ups.  However, I remain confused and somewhat spooked by the problem.

It is so hard to trouble shoot without being able to look a the files, time stamps, folder structure, etc.  I still think that the .DATA folder and contents probably got lost, or corrupted.  If you can find it, you should be able to recover the library via the program, or by creating a blank “text” file with the same name as the .DATA folder in the folder that contains the .DATA folder.  In >15 yrs of using Endnote, the only times one of my colleagues have experienced this kind of problem, was because someone was “cleaning up folders” and either put the endnote .enl file INTO the .DATA folder or moved it without mentioning it to anyone. 

I am going to try your suggestion of creating a text file inside the data folder.  Should the file name include “DATA”?  Also, once I create the text file, do I use the recovery command?

Thanks for the help.

The name should not include the .DATA.  So the libraryname.DATA and you create a libraryname.enl with notepad or wordpad.  save it.  Double click it to open it.  But I suspect that is what the “recover command” tries to do automatically. 

Oh and not IN the DATA folder but in the same folder as the DATA folder lives.  (which is where the current libraryname.enl file is already). 

I’ve had the same problem and in my case it was a problem with too long file names or more precisely too long folder paths. When I moved the .enl file and the .data folder out of the sub-sub-sub-sub-sub…folder they were in and placed them directly into "C: ", the standard library recovery process worked just fine.

I dont know why the error message in Endnote is not able to tell the user about the reason for the failed recovery, it would be useful.

best of luck to everybody!