citation order in text wrong

I’m working with Endnote X2.0.1 for Mac and want to changed the order of my citations - for example I want to change:

…can be attributed to educational training. [smith 2003, jones 2000, black 2001]


… can be attributed to educational training. [jones 2000, black 2001, smith 2003] 

I went into Edit Citations and used the up and down arrows to change the order. The unformatted order changed.  However, when I view the formated text, the order does not change.  What am I doing wrong?


You probably need to edit your format style.

>Edit>Output Styles>Edit “whatever your style”

Choose Citation >Sort order

Tweak with these options: Same as biblio, Author+Title, Year, etc

 I guess you’ll find the order you want.

Good luck

yes, I have tried that.  I have the citation sort order set to “same as bibliography”, and the bibliography sort order set to “order of appearance”.  I would like to change the order of appearance in the text as as well as in the bibliography.  The only way I can do it now is if I delete everything and re-insert it into the text in the correct order.  Is there any other way to change the order of citations?

You can highlight “only” the in-text citation where you want to change the order, then use “Unformat” button. Only that part will be unformatted. Then, change the order of unformatted text, like changing from {Smith, 2007 #10;Doe, 2008 #20} to {Doe, 2008 #20;Smith, 2007 #1}, then format again. Be careful not to screw up where you have semicolons. It should change the order of bibliography accordingly. (The method I learned from Leanne.)

I’ve tried that and the order of the unformatted citations is correct, but the formatted text is not. The semicolons are in the right place. I have the citations set to: [Bibliography Number , Author, Year, Title]  - does this look okay? 

It looks okay for in-text citation format. The thing I’m wondering is the separator for multiple in-text citation, because you use comma between. What is your separator? If it is comma, would other separators, like semicolon, change the behavior?

yes, it is a comma.  I changed it to a semicolon but it still doesn’t work.

I think I figured it out.  You have to set the citation sort order to “Don’t sort”.  I set the Bibliography sort order to “order of appearance”. 


OK, I got what you had.

You probably had these citations in the former places, which determines the “appearance order” already. When the same citations appear in the multi-citations in later sections, Endnote sorts them based on the order of bibliography number determined in the previous places. In that case, “don’t sort” is the only option. “Don’t sort” option is good for [Author, year] style in-text citation, but not good for [Biobliography Number] format, because in-text citation may appear like [11, 3, 9].

For most of the “Appearance order” bibliography formatting, in-text citation is “bibliography number” based, as I categorized number of styles recently in this thread.