Order of refs in in-text citations cannot be changed in Word

I cannot change the order in which references occur in an in-text citation in Word.
I am using Endnote X9.3.2.
I select a number of references in Endnote, then insert them in the Word doc using the ‘Cite’ option.
Once back in Word, I select ‘Edit & manage citations’ and change the sequence of the refs using the arrows, as I want them to appear by date, most recent first.
The order of the references does not then change in the Word doc.
I have ‘Instant formatting’ set to ‘On’ and have even edited the output style ‘Sort order’, to no avail.
This used to work and now suddenly doesn’t.
The only change I have made since I last successfully used Endnote was to update my Mac OS to Ventura 13.2.1.
Please help!

The sort options for in text citations and the bibliography are set in the output style (which I see you say you edited). Usually the in text is “same as bibliography” – but it can be set as “don’t sort” or some other criteria. I think you have to put them into the document in the order you want, and not sure I was ever able to reorder them any other way.

Have you tried inserting them separately with formating off, just taking out the spaces between the }{ then “don’t sort” and seeing if that works? Or change the sort to Year+Author?

At the end of the day, publishers usually want them sorted in a specific way, not the way the author usually wants!