Compressed Library (.enlx) error

Hi.

I can’t make a compressed library with my EndNote X4 in Windows7 32bit.

Similar problems existed in my previous notebook with EndNote X3 in Windows Vista 32bit on same library, ‘Library.enl’.

(Actually I copied my library files and folders to my new notebook.)

Pop-up window says as follows,

“Endnote cannot save or creat this file. Make sure the disk you want to save the file on is not full, write-protected, or damaged. (Library.enl)”

I quess there may be some problem on my library file, or something.

Please help me with this problem.

This kind of non-specific error is often the result of trying to unpack the library and associated files in a directory too “deep” in the structure (which would include the desktop and My Documents folders).  The file names in Windows can’t be longer than something like 250 characters, which includes the path/folder names and slashes.  If the PDFs had long names, this is often where the error originates from.  Trying to write those files in the deep folder name (which is the pdf name) and the pdf name itself, under the .DATA folder structure – it just chokes. 

1 Like

I am having this same problem however I am trying to save it to an external hard drive so the file name is not a long path. Any ideas on how to resolve this issue? I am ultimately trying to transfer my EndNote X3 library from one laptop to another laptop with X4. thanks

Hi,

I am afraid the long file name is not the reason for the problem. I have the same problem (EndNote X4 + Windows 7). 

I used a compreseed library to restore a new library using EndNote X4. And then, I just used EndNoted X4 to compress the newly generated library again. It just did not work (“can not create or save files”).  The compresed library I used was succeffully generated by another verion of EndNote. This means the restored library should also be able to be compresed. So that , the long file name is not the reason.

I do not know what is the real reason, but I think it might has something to do with the privilege of the user account who runs the EndNote. I am using a normal user account that do not have admin privileges to do some extra operations. 

Could you just check that and I think this is really a bug of the EndNote X4. I hope you solve this problem soon.

I am just another user.  I suggest that you contact Tech Support to report the bug from their website www.endnote.com

Thomson’s Answer to this question (which didn’t resolve my issue at all and they should have posted here, but apparently are too lazy to):

Thank you for contacting Thomson Reuters Technical Support.

This may happen when you try to save the compressed library within Program Files folder or even if the library files are placed inside the Program Files folder. Windows 7 will protect files in Program Files. Sometimes this issue may be related to permissions on your computer. Even though you have administrator rights Windows 7 applies stronger security to some locations.

When you create your .enlx file, where do you save it? Does it make a difference if you change your save location to the Desktop?

Please try to save the compressed library in the following location C:\Users[User Name]\Documents

If the library is inside the Program Files then I would also try to move the library to desktop and then make a compressed library. Let me know if you get the same error after moving the library to desktop or documents folder.

Each database consists of two files, *.enl and *.Data. Please make sure you both these files to same location.

If you are able to save the compressed library into the documents folder or desktop location then you may want to check the security setting for the location. Please see the following link for more information.
http://social.answers.microsoft.com/Forums/en-US/w7security/thread/938f2b50-b063-475b-8c5e-905d136df2e3

Note: You should contact Windows 7 technical support group before following instruction from the above link.

If the computer connected in a network then you should contact the network administrator.

If you cannot save the compress library on any location then sometimes the Administrator Account on Windows 7 may allow you to save the library. Please try to enable the Windows 7 administrator account and continue to make a compressed library.

Please see the following link to enable the administrator account.
http://www.windows7news.com/2009/02/03/enable-or-disable-the-windows-7-administrator-account

In addition, Please note that EndNote libraries that exceed 4 GB in size and/or 65,535 files cannot be compressed using EndNote. Please refer the following Frequently Asked Questions page for more information on this:
http://endnote.com/support/faqs/Database/faq9.asp

If this is not the case, as a test, please open the sample library and try to backup it. You should be able to find the sample library in this location: C :/> Program Files>EndNote>Examples>Sample Library.

Please find the steps to backup the library in the link below,
http://www.endnote.com/support/faqs/Database/faq6.asp

If you are able to compress the sample library, then the issue might be with the specific library which you are trying to compress and having issue.

Please move a copy of your library to your desktop. Note that you should copy both the .enl and .data folder to the same location.

You might try to recover the library. Please find the instructions the link below,
http://www.endnote.com/support/faqs/Database/faq3.asp

Please let us know if you have any questions or if this does not resolve the issue and we will be happy to assist you.

Based on the information provided above, this case will be closed and no further action is required on your part. However, if this does not resolve your issue, please reply to this email and your case will be immediately reopened for additional support.

hum… i also have the same problem :expressionless:

was trying to create a backup, but it looks difficult …

any tips?

I had the same problem.  It worked when I simply shortened the name of the compressed library.  My original name was “Article_Catalog_2011-12-02.enlx”.  I changed it to “ENL_2011-12-02.enlx” and it worked fine.

Note that I did not change the path nor the length of the name of any attachments.  I was also logged in on a non-admin account.  

Hope that helps others.

1 Like

My endnoteX5 has the same problem in Win7 32-bit system.

Either changing long name to shorter one or altering installation path to C:\user\user’s name\documents, even running as    Administartor , I still failed.

A more intricated method worked perfectly.

Download Microsoft “Windows Virtual PC”, then install it.

You’ll have a virtual environment to run endnoteX5.  In Windows Virtual PC program, problem gets eventually resolved.

Good luck~


This error is commonly come with longer names. Please try and use shorter names when you are compressing EndNote library.

@dslaley

Thanks for your comment on 12-03-2011 07:25 AM. Your simplest solution saved my big archived library today. Appreciate it. :smiley:

Thanks for your reply, your method worked for me too. I changed the file name to a very short (3 letter word) and it worked. I earlier had it as xxxEndnoteLibrary which I changed to xxx. I did not change anything else.

-Cheers.

I had the same error with every library I have, regardless of where I tried to save it.

I tried doing as the user above suggested. I shortened the name of the library without doing anything else. I opened the library I wanted to compress and then used File>Save a Copy… I saved it to a different directory with a shorter name, then opened the saved copy and it compressed without a problem. Note that like dstaley, I did not change any of the rest of the directory names or pdf names (some of which were to large to use the zip function).

Using Windows 7 pro, and Endnote X7.1 (Build 7705)

Hope this helps.

Tim

@dstaley wrote:

I had the same problem.  It worked when I simply shortened the name of the compressed library.  My original name was “Article_Catalog_2011-12-02.enlx”.  I changed it to “ENL_2011-12-02.enlx” and it worked fine.

 

Note that I did not change the path nor the length of the name of any attachments.  I was also logged in on a non-admin account.  

 

Hope that helps others.

 

Thanks to this community member … I was having difficulty saving a compressed library of 952 references including PDF attachments with long file names in X7.  I tried compressing without attachments, using this member’s suggestion of shortening the library name and it worked (resulting compressed file size = 777kb).  Then I tried my luck including the attachments and it worked too (compressed file size 862,000kb).

… / Brad MacMaster (Canada)