Conflict beetween style as formatted in endnote and style as it appears in word. Endnote 20


I have been consistently running into problems with Endnote 20 regarding styles and their layout in word. The styles are formatted correctly in endnote; however, when I insert a citation in word, there frequently appears to be mistakes in the format of the reference whether in footnotes or bibliography. I am using MHRA. I have downloaded the style from endnote and I have double checked that it is correct. This is also a problem I’ve run into with MLA as well. Another confusing aspect of this is that sometimes the reference is correct, but more often than not it isnt. I have scoured the internet for solutions, but I’ve found none particular to my specific problem. I’m adding screenshots to illustrate the problem.

For example, here is the MHRA style as formatted in endnote for books:

Since I’m a new user, I couldn’t embed more than one image. However, in the word document the colon between publishing place and publisher is missing. Comma between publisher and year is missing. Although, again, according to the way the style is formatted in endnote, these should appear in word.

Is there any solution for this?

I have downloaded the latest version of endnote 20. I have previously tried editing the style although I dont understand the purpose of that because it’s already formatted correctly. Can anyone provide some insight? This is causing a lot of problems for me.

I would put in a few more "forced separation"s before the Published|: and Publisher|, and replace the space before year with a “link adjacent” character. The forced separation is just the | character, but the link adjacent should be inserted from the “insert Field” dropdown. At least in my quick test, the colon shows up.

The only other thing that might make the colon disappear, is if the place published ends in a period, and endnote might be interpreting two punctuation marks and eliminating one. – It doesn’t do that for me in EndnoteX9, but Endnote20 might be different.


Thank you very much for your response.

I have tried the solution you suggested, but for some reason it hasn’t worked. Ref the following images. I ended up having a new issue where the reference doesn’t even show any punctuation not just the colons. (Again, I cannot post more than one image, but I edited the style according to your template and suggestions).

Sorry was away from the office. Can you show other images - of the template and the record entry in separate replies?

Thank you very getting back to me. I really do appreciate your help.

So here is the template for books that I edited as you suggested:

The following is the record as it appears in Word:

This is the reference from endnote

What’s confusing me more is that for some references it works. It is not a consistent issue. It’s that every once in a while I will get one without punctuation. Here’s another screenshot of other references with correct formatting (no change to template).

make sure there are no spaces after Cambridge in the one that isn’t working? (or put Cambridge, MA in the one that isn’t working?)

Deleting spaces after publisher and publishing place in the endnote record worked! Thank you so much. :slight_smile: