CWYW add-in appears in Word 2007 but doesn't work

I’ve been using Endnote 7 but just upgraded to X2 (skipped a few versions!). I had problems setting up version 7 back when I switched to Word 2007 but once it was happy it formatted my citations and bibiographies happily.  I’m surprised to be having issues with X2 and Word 2007 (hey, at least X2 in intended to be compatible!). The EndNote Add-in for Word does appear in my ribbon when opening Word- it just doesn’t work properly.

When using “insert selected citations”, first both programs completely freeze for about 30 seconds or more. 

  1. A failed server execution window pops up in Word. Once this window has popped up and been “ok’d”, both programs return to normal function as long as you don’t ask them to interact again. As soon as you do, the whole process starts over and another 30-60 seconds is lost forever in software hang-up lala land.

When working in a document that already had citations from the older EndNote version and asking it to “update citations”

  1. I get a paragraph-length citation with all fields in <brackets>, labels, codes, all stuck in {curly brackets}. This does not look like the temporary citations I am used to, that’s for sure, and my journal article was suddenly a couple extra pages long in Word. This was the most semi-successful response I’ve gotten and I can only elicit it when opening a document and asking EndNote to update the citations. After a reboot, I can’t duplicate this error anymore. I get the server failure error listed above in #1 not matter what I try to do between the two programs.

To be completely sure that I didn’t have a problem with conflicting add-ins, I disabled all other COM add-ins, but that didn’t help any. The older Endnote version (7) was running fine in tandem with the Acrobat 7.0 add-in, and I noticed that add-in wasn’t supposed to be a problem with X2 (based on the FAQ). 

I have already installed the X2 update available on the website, and I did that before I even tried using CWYW for the first time in X2. 

Any suggestions before I start bugging tech support? I thought that surely someone else has seen something like this- I was seriously hoping that X2 was not going to be as buggy in Office 2007 as the older version was, but I’m not getting a very good first impression.

Thanks in advance for any tips!

  1. The conversion from Endnote7 inserted formated references to X2 is complicated and I found it took some time the first time.  I highly recommend that you first unformating and then reformating the references the first time you open the paper and then save as a new document. 


  1. Alt F9 to get rid of the paragraph length fields.


To solve the core functionality issues, I had to do some registry edits in both Endnote and Word, run the repair utility, and now things work fine. I wish I could report exactly which registry directories I deleted, but guided by tech support I was deleting them pretty fast and didn’t get them all jotted down to post here. However, X2 works beautifully with Word now.

Leanne, you’re right about the strangeness of the citations conversion. The “update citations” worked automatically for a a handful of them, and unformatting and reformatting didn’t catch any more. However, I manually updated the rest of them (thank goodness this is a journal article and not a thesis). I am taking your advice and saving as a new document.

Also, thanks for the alt+F9 shortcut! Its way faster than digging through Word’s menu options to turn off that view.

Message Edited by emily996 on 12-18-2008 11:24 AM