Delete field in Ref Type

I would like to remove some of the fields that clutter up my references, and I found a message from Leanne stating that you just remove the field from the reference type.  So how do I do that?

I went into Edit, Prefences, Reference Type, {button} Modify Reference Type, and that gives me the list.  So if, for example, I wanted to lose the “Secondary Author” field, how would I do that?  I have tried highlighting the line followed by {Del} and {Ctrl}-X.

Do I have to export the reference type as XML, mark it up, and reimport it?  I stink at XML!

Edit, Prefences, Reference Type, {button}  Select the reference type you want to modify, and then delete the words (like in Book  the text in the Secondary Author field is “Series Editor” and you delete that - and the records that are Ref Type “Book” will no longer show that field.  (unless it already has text in it, and then it will still show).  

You can’t empty all reference types “secondary Author” entries at once.  – Although you are right, you could export the ref type file and consider editing, but probably not recommended!  

As I said above, if you do have a series author in some already existing book records, then they will still show.  You can select the records with text in that field and then edit them with “Change/Move/Copy Fields” tool to Clear the field.  I would show the generic field name you feel is superfluous and sort on that – I usually also show reference type when I am doing this.  then select the ones you want to erase the information from – “Show selected”  and tools>change/move/copy and select the field you want to erase, and clear field.  (this is not reversible).  

Do you know if this is just editing a view, or does it really edit my database?  For examply, if a particular publisher fills in a particular field that I have switched off (say Alternate Title) what happens next time I update references?  Does the update from PubMed or the publisher’s site write data into the field (but doesn’t display it any more), or is the data not written into the file at all and the stray electrons just wander off into the universe?

Ummn, never mind.  I just tried it for myself on a single record and EndNote crashed on me (multiple times).  Apparently EN doesn’t like it when you press “Update All Fields” and some of the fields are switched off.  Since I do a lot of my updates in batch mode with macros doing the button pressing, this will not work for me.  :angry: