Deletion of fields from reference type not "sticking"

I’ve followed the help instruction in EndNote “To delete a field from a reference type” in order to delete unwanted fields from a reference type. At first blush this works fine - the unwanted fields are indeed deleted. I then export the new Reference Type Table (eg new.xml).

The problem arises when I go through the process of reverting to EndNote defaults and follow this by importing new.xml. The unwanted fields reappear after importing new.xml.

I have tried manually deleting the offending fields from new.xml before importing, but still the unwanted fields reappear.

EndNote version: X2

Reference Type being modified: Chart or Table (at least that’s its original name)

Some of the fields to be deleted: Created By (=Author), Year, Name of File (=Secondary Author), Image Source Program (=Secondary Title), etc… in fact pretty much the only fields I want to be left with are Title and Number (though renamed) and most in the block of fields following Accession Number.

Any ideas on how to make field deletions “stick”?

Cheers, John

This is just a guess:  Is it because you have Data in a deleted field in the library?  The data in the fields is not deleted when you delete a field from a reference type format.

 

To remove all text from a field, use the “Clear Field” option in the Change Field command. You can also move data from one field to another using the Move Field command on the References menu.

 

but I haven’t reproduced your steps to see if this is the cause.

I decided to try doing your steps.  the first time, it happened just like you said - when I saved it new.xml, then reverted the preferences to endnote defaults, the resulting xml file had the original Charts and Tables and those settings.  perplexed I did it again, twice to new names, reverented to endnote settings, and the ones that said “second try.xml” and the one that was “try again.xml” stuck with the changes…  (hearing that weird music from the twilight zone). 

Hi Leanne

Perhaps the problem is that I want to remove (for example) “Created By” from this reference type without removing “Author” (or equivalent) from all other reference types? Or in other words, removing a field only works if a field is removed totally from all reference types? Not that this is what EndNote “Help” states.

What I have tried so far (along the lines of your experiment) is:

(a) just for the records with that reference type, used Tools > Change and Move Fields… > Clear Field (Author)

… and then deleted “Created By”, doublechecked it had disappeared (by starting to create a new reference), exported to newer.xml; reverted to the EndNote Default, followed by Import of newer.xml

(b) as for (a), but this time with a totally empty library.

In both (a) and (b) the “Created By” field reappeared (sigh!).

Cheers, John

I have finally discovered how to make the changes “stick”. To recap, the problem arises for those fields that I want to disappear whereas the default Reference Type Table (RTT) has a field there.

  1. When editing the new RTT, replace the unwanted field with a blank (Alt+32);

2. After importing the new RTT, make sure to click the Apply button.

Similarly when reverting to the default RTT, it is probably best to click the Apply button after clicking “EndNote Defaults”.

Cheers

John