EndNote 20 wouldn't work,Reinstalled X9 and now get .data folder can't be found even it's there

On my personal laptop, I Installed EndNote 20 (current version) upgrading from EndNote X9. When I launched EndNote 20 it was able to open my library files but the user interface would not operate nor let me navigate - nothing! I shut down and re-opened and same thing happened. I restarted my machine and launched EndNote 20 and same behaviour again. So I uninstalled EndNote 20 and reinstalled EndNote X9 and now EndNote X9 won’t open any one of my libraries saying that “the associated .data file is not in the same location as the .enl file” and to continue opening will corrupt the file. I tried opening anyway and sure enough my .data file was deleted. I recovered it using one of my two backups on external hard drives. I then tried to use the Endnote Recovery option and it said it “copied 0 files”. So now I am stuck!. However, as you can see from the attachment the .data file is indeed in the same folder as the .enl file. However, for ALL my libraries, now EndNote X9 won’t open any single one of them without generating the same error (also in attachment) and I cannot progress my Systematic Review, for which I am under time pressure. As a part time student that does the majority of my work at the weekend, to now miss an entire weekend of work will set me back a lot. Help!

1.EndNote Error Message_090721.JPG

Have you updated X9 all the way to X9.3?  Between X9.2 and X9.3 the database structure was changed (converted) and X9.2 or earlier can’t open or recognize an X9.3 or later library data folder.  (P.S. Even worse, if you continue – it will trash the X9.3 compatible .DATA folder contents.)

I hope you get this fixed

but the correct way of upgrade and re-install endnote, that is fool proof is as follows.

Before upgrade:

  1. create and endnote online account and sync you library to that

  2. go to endnote online and check that everything is there

  3. install the upgrade ( or if you need to install endnote on a secon machine) and start endnote with a blank and empty library, this will ensure that  the new library is created and stored correctly

  4. sync from you endnote online to your new  client installation.

I have the same issue with EndNote20. I would hope that Clarivate cares enough to fix this or properly test their products before releasing it with such bugs.

Super frustrating when you are working against deadlines!

Did you come right with EndNote20 or are you back to using EndNote9 now?