"EndNote error" upon formatting large file. exclude


I’ve tried to format citations that I manually entered in a document.

I’ve used Word 2007 and 2010 with EndNote X4 and X5 respectively without success.

Every time, EndNote prompts me to confim a citation (which actually has a correct syntax “IPCC 2007  #1000@Figure 2.1”), as soon as I confirm  I receive the same generic message. “EndNote error”.

I’ve tried eliminating that first citation. Then I simply get the message  “EndNote Error”.

I’ve also tried extracting sections of the text. When I take my Chapter 2, the message appears after encountering the following citation {Hajer 1997,  #238@12-13}… If I remove that one, it appears at {Washington,  #1019}.

Also, I would like to make EndNote automatically include the year even if I haven’t typed it fully in the reference.

Thanks for your help.


First, I the @ sign is to insert page numbers and I am not sure that it would work with Figure 2.1, which might be causing the error as it doesn’t look like a page number to Endnote.


The correct syntax for inserting only text is just to have the text there so the  {Abdul Motaleb, 1996 #4778`; Figure 2.1} (if you want the semi-colon, note the accent in front of it).  Also note the correct syntax includes the comma before the year and not between the year and the record number. 


As Endnote has tried to format citations, it may have some corrupted fields hidden in the document.  I would unformat everything and clean up the field codes with the Word command.  Make a copy of your document unformat all citations to their curly bracketed form, and in Word, select all CTRL+A and then CTRL+SHIFT+F9 to remove  fields. Fix your syntaxes in the unformatted citations (save a copy) and then try reformatting. 


To show years in citations even if you don’t enter them, you need to adjust your preferences. In endnote:  Edit>Preferences - under “Formatting” remove the tick from the “omit Author and/or Year from formatted citation if removed from temporary citation”.  However, this will affect both the “hide author” or “hide Year” citation edits, if you do tend to hide one or the other in your writing style. 


I had already tried what you suggested without correctingn the commas (too cumbersome!!). I expected EndNote to prompt me whenever one of the references had incorrect syntax, as it has always done.

Now I’ve gone through all the in-text citations and they all have the correct syntax… However, the problem persists…

The latest I’ve tried is to do it chapter by chapter… For some reason, chapter 1 and 2 have this generic error; Chapter 3 and 4 don’t seem to because they format the bibliography without problems.

it’s very weird because all Chapters contain mainly texts with just a few embedded images. I don’t use any different syntax from one to the other…

Thank you for your assistance.

So you tried cleaning up any corrupt codes with the word command? 

I did all that to no avail. The problem is solved now, though.

By formatting bit by bit I managed to home in on the references that were causing the trouble. When I copied and pasted them onto Notepad suddently the symbol “¬” appeared in between the code.

It wasn’t visible on Word and not searcheable either.

I’ve no idea how it got in there or what it means for Word.

Hopefully you guys can do something about this… At least improve the error message to: “unknown item in citation” or sth!