Reference error hash (#) + number.

Dear endnote community.

I have a problem with the reference function in Word. I am using endnote X7 in Word 365 ProPlus. I have been writing and citing in the same document for a few weeks now, but suddenly the citing function doesnt work as intended. Whenever I cite a reference it gives me this: {author, year #number}. For example: {Steinberg, 2008 #53760}

This just appeared out of apparently nowhere. If I open a new document referencing works as normal. It just seems to be this document where the error is. 

Thank you for the help.
Kind regards.

See this thread? Is this the same issue?  Make sure that the instant formating option is “on”. 

1 Like

Hello Leanne.

Thank you for the reply. It did the trick. At first I wasn’t able to turn instant formatting on. When I pressed “Turn instant formatting on” it went to the “insert citations window” and when I tried to add a reference it came back to this window without adding a reference, and without turning on instant formatting. The reason was that I used curly brackets {} in my text. When all these were removed word was able to turn instant formatting on.

So apparently I am not allowed to use “curly brackets” in a text while I cite and write. It’s a minor annoyance.

So thank you again.


Or you can change your temporary citation delimiters to square brackets or any combination of two characters that you don’t use anywhere else (%, & or $, etc).  then your “temporary citations” will be changed to [author, year #1927]and you shouldn’t have the problem.  This can be in the format bibliography menu or permanently in the edit preferences settings.  


I am having the same problem. I have followed the discussion.

However I am at a loss where to find “turn on instant formatting”: is this on my Mac or on Endnote?

When all the discussion make suggestions: am I looking on word ( i have word 2016) OR on Endnote…?



windows,  – in word, on the Endnote ribbon – see the attached 

Really sorry: I have a Mac.

I do not have Endnote on the ribbon and cannot find the display that the windows/ tools/ endnote offers on windows word.

Could you please sent an image of how I do this on a Mac

Huge thanks


Maybe your ribbon isn’t properly installed?  I see a similar ribbon in Mac’s MSWord 2016 in this youtube video?  You have the most uptodate word2016 and endnote 7.5 something or other? 

Thanks for your excellent support.

I can now see that my ribbon isnt installed properly: I dont have anything that looks like what i see on you tube.

I have just spent time trying to find a endnote video on “how to install endnote on the ribbon word 2016” and cannot find anything.

How do I install Endnote onto the ribbon of my Mac?

Yes, I have the most up-to-dat word 2016 and endnote (just checked)



Okay,  then I would go here!

Hi Endnote,

I have download trial version for endnote X8 and I am using ms word 2013. After install it, the tool of endnote did not appear in Ms Word, then I tried many ways suggested on the internet. Finally, it worked.

Then, I started to work with this software and input all of my references. Next, I felt very bad because again… I faced the next problem. I have chosen an output style and inserted all citations in the text word and again it didn’t work. There is a comment “cannot edit range”. In the last of sentences do not appear the number of reference, it just appears like this {Al‐Shahib, 2002 #91} and when i look at below, there is no any list of references, it is empty. I have tried to click “update citations and bibliography”, “instant formatting is on”, “convert citations and bibliography” and I didn’t work. The problem is still same.

What should I do?

You may be having a conflict with the Mendeley plug-in in Word and EndNote.

Please try the steps on our website:

Yes, you’re right Tony.

I have uninstalled the Mendeley and all of my problems solved suddenly.

Thanks a lot


Glad that I could help.

Try change to mode ON in word: select EndNote and search “Instant formating is ___” on/off. 

See picture in attachments 

solution endnote.jpg

Based on your screenshot it appears to be on.

What happens when you insert a new citation into Word?

Do you see {author, year record number#}

If not then Instant Formatting is on.

You might want to contact Technical Support:

Please contact Technical Support directly
1-800-336-4474 option 4 then 1 or


Im facing absolutely the same problem with EndNote X9 and Windows 10.

Is there an appropriate solution?

Thank you 

Julia Baranova


I had the same problem so i will tell you what worked for me goto endnote tool area on you word then click the update citations and bibliography its beneath style option .

It doesn’t work with me!

You may want to try these steps:

On some machines with Mojave, attempting to use the EndNote CWYW tools may result in returning to the EndNote library, or an Error message.

Mojave includes new Security & Privacy functions which can prevent EndNote from being able to correctly automate.  To correctly set these options…
1)  Go into the Apple menu
2)  Click System Preferences
3)  Click Security & Privacy
4)  Click the Privacy tab (along the top)
5)  Click the Automation options, along the left.
6)  Here, make sure that both “Microsoft Word” and “EndNote X#” are both turned on.

With this automation turned off, the Cite While You Write functions will not work.

If you continue to have issues:

Please contact Technical Support directly

1-800-336-4474 option 4 then 1