Endnote malfunctioning, Sorting does not work

Hi all,

Up until 2 hours a go in Endnote X6, when I clicked on sorting by author or any other field at the top of my reference library, it would sort my reference accordingly. Right now (no settings changed), when I click author it sorts strangely. I could not also sort it out by year or any other field. Please noted I tried to use Tools->Sort Library, but nothing changed. For example, a manual sorting of “Tools>Sort>First Author” did result in the same unusual sorting.

Does anyone know what’s going on here?


Did you try setting the Sort Options to: Author, Year, followed by whatever additional specified fields? (Note that the 1st setting is for Author and not “First Author”.)

Can you provide a screenshot  of the Sort  Options  dialog box?  Also, are you storing  the author names  in the  reference type  Author  field  in:   1) 1st name then last name  order;   or 2) last name  then 1st name  order?

BTW, are you running  the updated version  of Endnote  X6.0.1 -  refer to  the Endnote  software  update  page: http://endnote.com/downloads/available-updates

This sounds weird – you are talking about your clicking on the top bar, right?  – and I assume you tried  rebooting the computer? – you might try backing up the .enl and .DATA folder and then try recovering your library.  

if those don’t work, I would not hesitate in calling tech support!  

added in edit.  – I see a thread with a similar problem back with EndnoteX4 – and recovering the library fixed it.  http://community.thomsonreuters.com/t5/EndNote-General/Loss-of-Search-and-Sort-functions-in-library/m-p/37609#M7890 

Thanks. Recovering solved the problem.