Loss of Search and Sort functions in library

Hi, I have Endnote X4, and I have lost key functions, among them the Search box (top right) - when I enter a search term, such as an author’s name that I KNOW I have in the library, it comes back with 0 results. This is the case whether or not I click in the library window before doing the search.

Second, Endnote will no longer sort references in the library window properly. When I click on the Author name field heading, it changes the order of the entries, but not into alpha order. It will NOT sort by any other heading at all. I’ve tried changing the display fields and their order, but to no avail.

I’m a bit beside myself - I have hundreds of references in my library, and really need these sort and search functions to work!!!

I work across platforms - I have Mac and PC versions, and save my libraries in Dropbox in order to open them on my multiple computers. This approach has worked for a few years seemingly without a problem. But all of a sudden, these problems have arisen, on any computer that I open the library on.

I have tried saving different versions of the library, changing the filename, etc, in case the problem is some corruption with the file. I haven’t yet tried uninstalling the program, that would seem the next logical step unless there are just some settings I need to change.

Any suggestions??? Thanks.

I have solved the problem for now by recovering the library, as detailed in this thread:


Happy times!!!