Endnote stopped working

Hi, I am a relatively new user of Endnote, so bear with me if I haven’t figured out all the tricks yet. I have been importing folders of PDFs into endnote, and most of the time Endnote is able create a reference automatically, but with the occasional PDF (say something like a scanned product brochure) I have to create reference info manually. There are two files in particular that are sitting in the “unfiled” category, and everytime I try to click on them to create the reference, the program stops working. I figured there was probably something wrong with the files themselves, so I tried to just delete from the library, but I can’t go anywhere near these two references without the program stopping working. Even clicking on files that are right above or below, that I KNOW are OK and that I can access/modify elsewhere, will cause Endnote to stop working. I have tried to fix endnote via the “repair” feature in windows control panel.

How do I fix this, or at least get these files out of endnote? I can’t seem to navigate to the files themselves in the windows directory to remove them that way.

By the way, I am running the newest version of Endnote (X7.1).

Have you tried importing the library into a new library?  – If that doesn’t work (it might hang when it get to them), I would suggest calling tech support and they may have tools to explore and fix the library.  

Or copy the refs bracketing the problem entries into a new library - and just reretrieve the ones right next to it or sort in a different way to get them?