Endnote X1 file attachements error - "This URL(\\) could not be launched"

When I build the reference, I often insert the corresponding PDF file as a “relative link”. This copies the PDF file to a local directory. Then I can share this reference database with my collegues. However, the endnote sometimes cannot find the PDF file, and it give an error message “This URL(\) could not be launched”!

How to solve this problem?

Thanks in advance.

Does this happen only to your colleagues, or to you as well?  Is it a permissions problem, or a difference in the way those directories are “named” in their environment?

Thank you very much for your help. We have a volume license of the endnot, so it shouldn’t be a permission problem.

The strange thing is that, sometimes after I close the database and reopen it again on the same computer, it cannot find the attached PDF anymore.

Is there any limitation on the length of the name of the PDF file?

In regard to - “Is there any limitation on the length of the name of the PDF file?” - EndNote does not have its own specific limit. However, the Windows operating system typically imposes a limit to the overall length of a file “path” to a maximum of 244-260 characters - depending on the exact conditions/version of the operating system. EndNote’s attached files are impacted by this Windows limitation as are nearly all other files used on a Windows-based computer.

I would recommend moving the PDF / or the EndNote library (including .data folder) in question to a location that is not deeply nested in a set of folders and see if this resolves the issue.

Yes, there must be.  I recently was helping someone attach PDFs and PDFs with very long names could not be dragged and dropped to the record.  We noticed that they were long names, and if we shortened them, they dragged and dropped fine.  Maybe that is the problem? 

Thank you all for your kindly help.

It maybe caused by too long name of the PDF file. However, the long name of the PDF was accepted by winXP. And when I insert the PDF file, the endnote accepted this PDF without any warning. But it cannot launch URL to reopen the PDF after I restart the database.

Maybe this can be solved in future?

Message Edited by yizhou on 06-18-2008 05:04 AM

I found the reason now. When insert PDF with long name, sometimes Endnote copies and cuts the file name to “…~1”, but the URL is still using the full name.

Hope this bug can be fixed soon.

Hi, i have the same problem like you

how do you solve it ?

i cannot open all my pdf attachment eventhough the file name is short

im using endnote x1 also, word 2007

i can launch txt, jpg, word, but not pdf, can anybody help me why ?

im using adobe acrobat for viewing pdf file

helppp plzzz

thank you in advance

Hi everyone!

I not sure if this may help but is in option… I got the same problem with file attachments wend I move my library to another computer I can not open the attachment(pdf), after while I see like the endnote data base crate a temporal folder with the extension “.Data” inside that folder hold all are script links and pdf files.

I check the folder on my original library and get back to the one I transfer to another computer and I see that i have a lot of missing files. what I did i copy the missing files and pasted to the new one it works… also i did this on a file server of the company where I work and now every person inside the company can reach the database and pdf files

suerte amigos!:smiley:


We’ve just encountered the same problem with EndNote X and Adobe version 7. the Library had been copied accross to an Ipod and copied back. The PDF files could be opened directly, but the “this URL could not be launched” appeared if you tried to open directly from EndNote. The solution was to run a repair on Adobe Acrobat, which you can access from their web site.


Could you please discribe in more detail which update should I install for acrobat 7.0? Thank you very much!

Hello, I have the same problem :

-Endnote X1 on Vista

When I attach a file I can’t re-open it.

I think the problem comes from the link used by Endnote X1 : "\D:…\mydoc.doc "

It consider that my file is on a network drive (" \" ) whereas I use a local drive!

For example when I put the link present in the error message in the run window (start > Run), Vista don’t find it because it is looking on the network (my DNS doesn’t know “D” ) instead of in local !

The good link should be : “D:…\mydoc.doc”

Please if you have any response tell me, because if I can’t use file attachement => I can’t use this tool… :frowning:

Message Edited by samuel on 10-25-2008 04:48 AM

Message Edited by samuel on 10-25-2008 04:48 AM

Message Edited by samuel on 10-25-2008 04:50 AM


I have a similar problem Endnote X2.0.1 and Vista. All files attached to the library are moved to the .data folder. However, the .pdf files cannot be opened and the same error message appears. 

Does anyone know how to fix this?


PS: I am also using Acrobat Reader 9.0. A repair install has been made without any resutls. 

Message Edited by inic on 10-27-2008 07:13 AM


This is an issue that can happen with the different Adobe PDF viewing programs.  When you tell EndNote to open a PDF, EndNote tells Windows to open the PDF.  Something about the way the Adobe programs register with Windows how to open the PDF will cause the error.

Currently the only resolution we have besides using a different PDF viewing program, is to create a Windows Batch file to open PDFs using the PDF software of your choice.  While this may seem redundant, it seems to be the only way to have the PDFs open consistently with the Adobe programs. 

  1. Open My Computer and go to the folder where you PDF viewing software was installed.  The goal here to find the exact path and name of the PDF viewing program.  These are the default installation locations for Acrobat Reader 7 and 8:

C:\Program Files\Adobe\Acrobat 7.0\Reader\AcroRd32.exe

C:\Program Files\Adobe\Acrobat 8.0\Reader\AcroRd32.exe

  1. Go to “Start > All Programs > Accessories > Notepad”.  You would need a line like the following:

start “” “C:\Program Files\Adobe\Acrobat 7.0\Reader\AcroRd32.exe” %1

You would need to replace the “C:\Program Files\Adobe\Acrobat 7.0\Reader\AcroRd32.exe” with the path to the PDF viewing program you want to use.  Note that this must be in quotes, there is an empty set of quotes between start and the path, and that the line ends with %1

  1. Go to “File > Save As” and set the “Save as type” to “All files”.  Browse to your My Documents folder and save the file the name “PDF_Wrapper.bat”

  2. Open a My Computer Window and go to “Tools > Folder Options”.  Click on “File Types” and select the “PDF” extension.

  3. Click on the “Change” button and then click on “Browse”.  Browse to your My Documents folder, select the file “PDF_Wrapper.bat” click Open and then click OK.  Click Close to close the window.

Browse to a PDF on your computer and double click it to verify that you can still open a PDF.  Then open EndNote and try opening a PDF.  Note that your PDF viewing software may inform you that it is not the default viewer, you would not want to have it be the default viewer.  This may also change the icon that was used for your PDF files.


I had the same problem with Endnote and PDF file attachments.  Creating the batch file fixed the problem- thanks!  Only thing was that it took me a while to find the “File Types” because I’m using Windows Vista and it is not under Folder Options  So…

  •  For part (4) - Go to Control Panel > Program >  Default Programs > Associate a file type or protocol with a program and then select “PDF” extension.


Thank you for your tips, it works ! Even if it’s a little bit dirty…

To conclude, I use this tips for word document. I have no problem with PDF (I use Foxit Reader).


First of all I am really surprised by EndNote’s incompetence in tech support and offering “half-baked” bug fixes like the “PDF-wrapper” batch file. The auther even acknowledges that this will change the PDF file icons. Is this the official solution? You have to be kidding me.

Here is how I was able to solve the problem on windows Vista:

  • Go to Start Menu / Control Panel (Classic View) / Default Programs / Associate a file type or protocol with a program

  • Scroll down to find the entry for “.pdf” extension.

  • Click on Change Program and select “Adobe Reader” from the list. Even though it is already set as the default program resetting this will fix the registry entry and force it to work properly.

And it works. No wrappers.

Sorry End User, while I agree that the official solution seems cumbersome, the proposal to re-associate through Control Panel PDF’s with Acrobat has not worked for me.  I will just have to try the packaging solution above. 

Actually to save time and pointless meddling with my computer I just uninstalled Acrobat 9. I’m back to Acrobat 7 and my pdf’s will open from Endnote again.  I literally went 2 steps backward to stay in the same place.

I like to name my files with the title which can make them really long.  I copied my library to a flash drive and onto another computer.  The file names had been truncated when I copied the flash drive onto the other computer. 

The path on both computers was the same which made the following solution possible.  Had the base path on the second computer been longer this would not have worked, as the path length was already at its limit.

Since I had some unicode characters, zipping on windows was not possible.  I instead downloaded winrar and archived the library.  I transferred this rar file over to the other computer and used the function “extract to here” as otherwise it complained about the file character limit.,

Two Endnote suggestions seems to arise from this:

  1. There should be more flexibility in specifying the base folder for a reference based on its inputs, something like

[year]_[first author] or whatever (this would be user specified) and perhaps even unique for different styles with a default base style provide.  The default name is really long.  In addition the file name itself should be modifiable as well although this gets tricky with multiple files for the same reference (Perhaps only applied to the first reference).

  1. Since the problem is known, an option should exist to fix all bad links, whereby the library checks if a file exists, and if not does a local search within the directory to find the best match (This is for relative links).  I’m not sure for multiple files if it is possible to always back out the matching short file names or not.  For example in some reference folder you might have the following:



These might become (I’m not sure about the rules on the name length, so this format might be wrong, although the ~# seems to be consistent)



From these shorter names it is relatively obvious which ones belong to which.  In this case it seems appropriate for EndNote to switch its links to the shorter paths.  Granted I’m not sure if that is always the case and this is really specific to relative links.  When there is only one file link in a reference folder this matching becomes trivial.

Good luck everyone!