endnote x4 can't open pdf attachments


I just upgrade to x4 to take advantage of the pdf import function.

the import function is working well, but the attached file couldn’t open. and message shows

 " the url"C:\Users\Michael\Documents\My EndNote Library.Data\PDF\ats_brochure-2678615047\ats_brochure.pdf" could not be launched".

I checked the path is right, and I can open the file  from the folder(\My EndNote Library.Data\PDF).

my systems is windows 7, and the pdf viewer is Adobe reader 9.3.4.

Please help. thanks.


solved. I have also acrobat installed beside adobe reader. I change the .pdf  connection (control pannel->Programs ->default programs) to acrobat, then it works.


I’m having the same problem but don’t have Acrobat - only Adobe reader. Any other ways of  sorting this out?

First I would check whether it appears that the total file name with the entire path is very long.  Note that the file name is also used as the folder name, so if it is also deep in the folder hierarchy, you can end up with a total filename that excedes the Windows file name limit of something like 250 characters. 

Oh, yes.  Have you updated to the 4.01 version of X4?  I think there was a bug fix that affected the ablility of endnote to open PDFs on a network drive? 

I think I solved it.

Firstly I got the upgrade to 4.0.1, although had to do this from the website rather than from within EndNote.

Then, when I tried to attach a reference I unchecked the box “copy this file to the default attachment folder and create a relative link”

When I didn’t have this box checked, I was able to open an attached pdf. Funny thing is, now the box is checked again and I am therefore using the copy function, it still works. Problem completely solved.

So in summary, upgrade, then experiment with checking and unchecking that box.

The following is what I found on endnote website and it works for me.

EndNote: Troubleshooting launching new PDF attachmentsIf EndNote is unable to launch newly linked PDF attachments within EndNote library records, there may be a problem with the versions of Adobe Acrobat installed on your computer.  To verify the cause of this behavior, download another PDF reader.  Click the following link, and download “Foxit Reader - Free”.  After installing Foxit, double click on a PDF outside of EndNote to make certain Foxit has been set as the default PDF reader. Then try creating and opening a new PDF file attachment within an EndNote library record to see this resolves the problem.

I can now open most of my attachments, except for those with long file names. 


I had the same problem after I upgraded to a new Mac. I found that the files were not being copied to the PDF directory (even though EndNote appeared to be importing them just fine). I ended up changing the permissions on the EndNoteLibrary.Data directory, and applied those permissions to all enclosed items. This worked for me.