Endnote X3 and Word 2007 "Invalid Class String"

Hi there,

I recently installed Endnote X3 on my computer, which runs Windows Vista and has Microsoft Word 2007. It worked fine the first time I used it, but now everytime I try to insert a citation I get an error message with “invalid class string”. 

I have tried everything possible, the instructions on the endnote website didnt help, I uninstalled and installed endnote again, I tried logging on as an administrator and trying to run it, I took it off word and then put it back on, and NOTHING has worked! I am trying to write my thesis and installed the new version of Endnote as I was promised it was a hassle free switch over from older versions and I wouldnt have any problems!

If anyone can help me I would be so grateful as I am going INSANE!!



I have a similar setup as you and fortunately did not encounter your situation. BTW, you should install the program using the administrator account/status  - it’s unclear to me if this was the case as you mention “logging on as an administrator and trying to run it” which sounds like you use the administrator status after installing the program…

There’s an FAQ on the Thomson Reuters site concerning the same error message (albeit for Endnote X2 and Vista ) but decribes modifying the registry:


This is another thread about Invalid Class String error

Look at the second post of this thread.


If none of them works, I strongly suggest to call Tech support, and have them figure it out for you.  With the upgrade purchase, you are entitled for that. When you solve the problem, please post the solution, because this Invalid Class String problem has been posted several times here and doesn’t seem like people figured out.

Message Edited by myoshigi on 11-17-2009 08:08 PM

Thanks for your advice, I had already tried both of these things but neither of them worked. However, I did just open EndNote X3 through “Run as administrator” and opened Word through “Run as administrator” and I could get it to work.

However, this is a lengthy process to open both of these programs like that and I dont understand why I cant just open the 2 programs normally and have them work?! is there any way I can always open these two programs as an “administrator”?

Message Edited by annapatten on 11-18-2009 12:06 PM

I’m unclear as to how you’re setting up the “Run as Administrator” option but could  you check the Properties setting for both MS Word and EndNote X3 to see if the “Run as Administrator” box has been selected?

  1.  If you have desktop icons for each program, place your cursor on the icon, right-click and select PROPERTIES. (If you don’t have desktop icons. go the  Start Button, All Programs, locate the program file then right-click.)

  2. On the Properties box, click the tab that says SHORTCUT, then the button named ADVANCED. Check the box that says “Run as administrator”, then click OK to close the Advanced Properties box.

  3. In the Properties main screen, click the APPLY button then close the properties box.

This Invalid Class String error is a real catastrophe. In our group we tried to solve this problem on many computers for many hours. Now we will remove endnote and will never use this program.