invalid class string office2007,vista,endnoteX1

Having the following problem: if I do ‘insert reference’ in office 2007, it gives ‘invalid class string’. It is a fresh install of vista ultimate, office 2007 enterprise, endnote X1, all completeley updated. Already installed Endnote in a different folder. Gave all users full access to the folder. Is there a solution?

Thanks a lot.



If you are receiving an “Invalid Class String” error when trying to use EndNote from within MS Word on Vista: First, go to the EndNote website and check the FAQ’s for this error. There’s at least one FAQ on this topic with several possible solutions. If that doesn’t work, shut down MS Word and EndNote. Go to the Program Files location for Endnote. Right-click on the EndNote.exe program and select “Run as Administrator”, just once. Once EndNote has run at least once as an Administrator, I suspect the class information in the registry is properly updated. After this, running as the current user should be fine. I’ve tried this and it solved my problem when all the suggestions up on the FAQ did not work.

I have the same problem ‘invalid class string’ under user accounts when inserting citation to MS Word 2003.

I Installed EndNote X2 at MS Windows Server 2003 Standard Edition under Administrator account. I’ve tried to run EndNote.exe under Administrator rights, I’ve tried to follow recommendations written at, but it doesn’t help.

Any other solutions.

Thanks a lot.


Have you called Tech support? After trying the FAQ recommendationswhich you said you have, (and maybe see this thread), that is what I would do.