X3 gives "Invalid Class String" on Vista/Vista64; FAQ answers don't seem to apply

Just installed X3 on Vista/Word 2003 and Vista64/Word 2007 and get “Invalid Class String” whenever trying to use any Endnote function in Word.  Opening an Endnote library first, then opening Word didn’t help, and the other FAQ info doesn’t seem to apply.

Any suggestions? Thanks!

Armand, I hope you don’t mind if I add my experience on the same issue with X3.

I have also recently upgraded from X2 to X3, using it with Word 2007/Vista.  Directly after the installation, everthing worked fine, but on the second day, I also got the “Invalid class string” error.  Trying to resolve the issue with the help of the FAQ did not work either.  In particular, the dectivating and re-activating of the COM-Addin did not work, because I could not de-activate.  Word told me the “The add-ins are installed for all users on this computer, and can only be connected or disconnected by an administrator.”  I was, however, logged in as administrator.  The rest of the tips from the FAQ did not work either.

So I completely uninstalled Endnote X3 (and also the X2 version, which I had left on the computer during the upgrade), and re-installed X3 from scratch.  Everthing worked fine from then… until today (roughly a week later?).  Again, I encounter the same “Invalid class string” error message when e.g. trying to insert a new reference.

What I find surprising (when reading the FAQ) is, that when I start X2 first, then Word, the “Insert citation” button in X3 is active. Shouldn’t that be inactive if the Add-in would not load and therefore the macros that connect X3 and Word did not run?

I have tried the  “Configure Endnote” tool to fix this issue, but that did not help.  Same result when “repairing” the Endnote installation.

Anyway, I  do not want to re-install the whole Endnote program again, as I suppose it won’t last for long before the "Invalid class errors"show up again.

Any advice on how to fix that?

Actually, the problem is resolved - at least for me.  I hope this also helps you, armand1.

What worked this time was advice from another post in this group; closing both X3 and Word and the running X3 “as Administrator” from its folder (right-click on the .exe).

Even though Endnote was not working properly at that time, it was working again once I restarted it from the start menu (not as Admin).  Everything seems to be fine now, hope it does not change any time soon…

Anyway, I (and probably a lot of other folks, too) would appreciate it, if Endnote would just run without all that hassle.  Maybe the programmers can look into these user rights issues under Vista and make the program more stable?

I should mention that I installed X3 from scratch - there was no previous version of Endnote installed.  I will try experimenting with the run as admin – thanks!

Once more, problems with the Endnote X3 under Vista/Office 2007.  I am not sure why, but somehow Word forgot how to connect to X3 again, and I get the same old “Invalid Class Sttring” message, whatever I try to do.  Resolving is easy; same procedure as above:  closing both X3 and Office, starting X3 as administrator, then Office.  Like this, X3 also won’t work, but it will, once both applications are closed and regularly restarted (not as admin).

Not sure why that is, but it is very annoying (esp. for a rather expensive program!!) as it now happens every couple of days… Re-installing or fixing of Endnote did not help either :frowning: