Invalid Class String - X3 on win& x64

This is driving me nuts!  I installed Endnote X3.0.1 on win7 x64, office 2007, and it worked fine for about a week.  Then I started getting ‘invalid class string’ whenever I used any of the CWYW commands from within word.  The ‘configure endnote’ program does absolutely nothing - whether you select to remove or reinstall components, it does neither.  Eventually I reinstalled & the problem went away, then it came back a week later.  That time I did a variety of things including running word as admin & manually removing all cwyw components, then running a repair from control panel/programs & features which fixed it for another few weeks, now it’s happenned again.  This time the repair didn’t fix it, but repairing the endnote installation followed by running endnote once as as admin, fixed it.

This is driving me nuts, every time the solution is different, the automated tools (‘configure endnote.exe’) do nothing.  There are several people with this fault in htese forums, and it keeps recurring.  What’s the permanent solution?

Just curious - have you tried changing EndNote’s compatibility within Windows 7 to an earlier OS (e.g., XP, Vista, etc)?

I haven’t - I’d regard that as a kludge if it worked, given that X3 is meant to be win7 x64 compatible!  Since the problem is in the CWYW tools, it would probably also neccessitate running word in compatability mode, which would mean running acrobat in compatibility mode, and it would get silly very quickly.

This could potentially be an issue with Windows 7’s built in restrictions (as part of it’s security measures).

This can prevent EndNote from re-writing certain registry keys, resulting in this Invalid Class String message.

One potential solution is to disable the UAC options on the system, to allow the user to freely make these changes.

The other solution is to limit the ability of the system to remove the keys, so that there is no problems re-writing them.

To do so…

  1. Close all open programs.
  2. Go to the EndNote X2 program folder. This is typically
    C:\Program Files\EndNote X2
    C:\Program Files\EndNote X3
  3. Right click on EndNote.exe and select “Run as administrator.”
  4. With EndNote open, click on the Start Menu. In the search box type “regedit” (without quotes) and hit enter on your keyboard to launch the Registry Editor.
  5. Expand the “HKEY_CLASSES_ROOT” folder and locate the “EndNote13.AddinServer” key.
  6. Right Click on the “EndNote13.AddinServer” key and select Permissions.
  7. Click Advanced. Then click Add.
  8. In object name, type “Everyone” (without quotes) and click Ok. If you see “Everyone” listed here already, select that and click OK.
  9. In the Permissions entry window, go to the Delete row. Click Deny and then choose OK.
  10. Close the Registry Editor and close EndNote.
  11. Start EndNote and Word normally.

Does this help to resolve the problem?

Please let us know.



I’m certainly not turning off UAC, that’s a useful security backup and every other program I have is able to work fine with it.  Regarding setting the registry permissions, ‘everyone’ already has full control of that key.  I could deny it and see what happens, but since ‘everybody’ already has ‘full control’ surely endnote is able to modify it currently?

It’s not a question about control in this case.

It’s an issue with removal, and recreation.

There’s no way to allow Full Control to something that hasn’t been created yet.

In this case, we’re trying to limit the systems ability for this key to be removed.

The Invalid Class String issue is quite often an issue with this key being created.

If we prevent it from being removed…  we eliminate issues with recreating the key, since it’s already there.



Got you - I’ll change the permissions & see whether it re-occurs.