Endnote X7 freezes when trying to find reference updates


My endnote freezes when I click on ‘Find references update’ on any reference in a library.

I’ve seen other people having the same problem but without answer

I run mac OS X 10.10.5, and the latest version of Endnote X7.4

The problem seems to be easily reproducible: I have installed a brand new version of Endnote on my brand new mac, and it’s been doing the exact same thing as on my previous install on my previous mac.

It is not library dependent etiher: it does the same thing with the default new library created on install

It is not dependent on network, I have tried a two completely different WiFi configurations

I don’t sync with any online account

What I am doing: I create a new reference and only fill the ‘DOI’ field with an existing journal article (e.g. on Wiley)

I save the reference and then click on “find reference update”, and it freezes with the mac OS wheel indefinitely running.

It was perfectly working on previous version (X6 and I think X7 on mac OS X before Yosemite)

Can we do something about this?


Im having the same problem, any soltion for it??  help please 

I had the same problem. I spend about a month going back and forth with EndNote tech. The problem seemed to be something to do with the User acount. Tried rebuilding the library, reinstalling, starting over with a new library, nothing really worked. While trying to troubleshoot with me, I found that my admin account had no problem using the “get reference updates,” while the user account still crashes. The solution I was provided, was to migrate accounts, that’s not really do able for security reasons.  What I find interesting is that it appears someone had a similiar issue with windows


After reading this I got fancy and tried running Endnote as the admin from terminal, even sudo to run as root, but it doesn’t open my local library. So that was frustrating.

I’m still at an impass to get things working normally, except to keep my library on a flashdrive, and kick it over to a different account to update my references…

Completely resetting my preferences seems to have done the trick. Though, it seems if I change the preferences, specifically enable the autoimport folder, it messes everything up again.


Thank you for your input!

I have tried to reset the preferences as you suggested following the procedure given by the knowledge base


but it still doesn’t work!

Have you reinstalled everything and set up a new library also?

I know this is an old thread, but seeing things stil haven’t been resolved.

So I’ve encountered this problem over and over. I dont think the solution is th resetting the preferences as previously mentioned. Though that maybe a major issue, I can’t say that following there instructions and manually deleting preferences has actually done anything.

For me the current solution I seem to have found is as follows:  When you have to “Get Reference Updates” and it crashes. You should restart Endnote, go to import, and select a PDF that has the DOI imbedded in it (anything from a journal in the past year). When you do this Endnote imports the file and pulls the metadata. If this is success, you should be able to then use the “Get Reference Updates” option.

It seems that “Get Reference Updates” has some connection routine that gets broken occasionally. Whatever the metadata routine is upon file import appears to be different/orginates from some where else. Either way the metadata routine on import overwrites the previously “broken” coonection routine associated with “Get Reference Updates” and it works again. Obviouslsy I dont have access to the source to verify this, but I suspect that is what the issue is.

Hope this helps

July 2016, this issue has still not been resolved…

Why does this product cost money?

July 2016, this issue still has not been resolved.

Why does this product cost money?

Thank you for your input

Actually I have not tried this method, as the last Endnote update seems to have resolved the issue.

I don’t seem to have the problem anymore, even with a new note with only the DOI field filled.

I hope this will remain stable