HELP! Endnote X2 not importing .xml.

I used to use Endnote 8 with Office 2004 no problem. However we have recently upgraded to X2 and use it with Apples Pages. Our refs are all deposited in 'Papers" reference management database beforehand. However when we export all the refs in .xml (or indeed any format such as txt, ris etc) We CANNOT import it into X2.

The import function is never lit (and button doesn’t work). If we select ‘open library’ the only files we can load are the old ones with “.enl”. What’s more, even though it is X2, it says Endnote 8 at the top of the program when we load the old.enl databases. We uninstalled Endnote 8 beforehand already.

If we change the extension of abcde.xml to abcde.enl and open then the library is empty. What’s going on? This program cost us alot of money and we can’t use it!

In order to import, you have to have a library open, either an empty new library or an existing library.  Otherwise, “import” and just about everything else will be greyed out. 

  • if the header says endnote8, it must still be installed somehow? 

If I remember correctly, on  a mac, holding the shift key will allow you to open other files named without the .enl ending.  but you must import a properly constructed .xml file, or .ris file into a library.  On a pc some file types can be opened and “automatically” imported, but it will ask the user to open or create  a library first. 

Thanks for your reply, but no none of it worked. It’s weird.

Found it!!!


I am having the same problem with Endnote X2 unable to import .xml files exported from Papers.  I tried the instructions for changing the Endnote preferences in the link you posted, but Endnote is still not recognizing .xml files.  I was wondering which preferences you changed (if any) to get the import function working.

I am running OSX and just recently installed Endnote X2.  Thank you for your consideration.