How to download references to Endnote from Firefox browser?


I’m wondering if you could help me. I’m using Firefox 3.0.6 as my internet browser and have been searching for articles on the website. It has an in-built function for exporting citations of the chosen articles to leading bibliographic software backages, Endnote being the first one listed. I have had no problems with exporting references to Endnote using this when I’m browsing the website through Internet Explorer. 

The probem arises when I access the BMJ website (and indeed other online journals or databases that have the “export citation” function) using Firefox as my browser. When I clicked on the button to “Download all citations to” and then select “Endnote”, there is a box that says, “saving… [name of article]”, but I cannot see the actual references in any of my opened Endnote libraries themselves.

Can anyone point me to where I’m going wrong or if there is something that I need to keep in mind for downloading references to Endnote via the Firefox browser? If this query has already been raised elsewhere and solved I’d be grateful if you could let me know too. 

I do hope that it IS possible to download references to Endnote via Firefox, as I really don’t want to have to go back to Internet Explorer again as my default browser. 

Thanks in advance for your help with the above. 

Did you try out Zotero, if so, see the below threads:

1 Like

Thanks a million Leanne for your quick and helpful response! Yes I had downloaded the Zotero pluggin but had no idea that it’s meant to affect my Endnote references. I am so glad that somebody had already done the hard work of finding out the solution from the Zotero forum (it was impossible to locate the thread myself without your help as all that was visible there are threads about IMporting to Endnote not exporting, and the Zotero documentation on import/export themselves have not included ANY info on the matter, just blithely stating that its references could be exported to Endnote).

So my problem is now solved by setting the config to false so that Zotero won’t interfere with my Ris files anymore. Thanks again for all your help :)