how to get into Microsoft visual basic for applications and into Project Explorer

Using V5.1

I just had a computer reinstallation and lost my macro. I have redone it many many  times and I still have screenshot instructions.

My problem is that I cannot get to the visual basic for applications window. When I press alt+F11 in word all my icons on the  title bar come up as Alpha letters and numbers in boxes… That is ok because it has been happening for a long time and I have always been able to find project explorer when I go to endnote…This is not a problem.

I went to endnote but I cannot see hoe I can get into  Microsoftt visual basic for applications… I know how to set it up but I cant see how I start my project. I seem to be missing part of the toolbar.I cannot get into project explorer.  I do not have a view icon. All I have is the basics - file, edit, references,  groups, tools, windows and help… Even the help menu isn’t showing me anything about visual basic for  applications or project explorer… I should have icons in my toolbar.

I hope someone can help please. It is not about the actual macro I am going to use but how to get into Project Explorer to set it up… Strange.

What version of Microsoft Office are you using? By any chance did you have MSO 2003 (or earlier) and now have MSO 2007 or later with your new computer? The shortcut for switching between MS Word and the Visual Basic for Applications editor is still <Alt+F11>, but the effect of pressing the Alt key by itself is a bit different.

From your description of what happens when you press the keyboard (“Alpha letters and numbers in boxes”) that’s exactly what happens when you press and release the <Alt> key in MSO 2007+. To activate the command directly, you need to press and hold the <Alt> key while you press <F11>.

You can also get to the VBA editor via the ribbon. If the “Developer” tab isn’t showing, go to Word options (click the round MSO logo “blob” at upper left of the Word window, then “Word options” at lower right, then “Popular” (should be showing already) and click “Show developer tab in ribbon”. Then click Developer tab, “Visual Basic”. [you could also do this by pressing and releasing <Alt>, then pressing ‘L’, then ‘V’ when the “letters in boxes” are showing; it’s the same as clicking with the mouse.]

Hope this helps.


Hello Ron

Thank you for this

Yes I am using Win 2007. My tech was able to give me a compatable laptop and had installed a hard drive recently and ghosted my programmes onto my external hard drive… I was able to purchase a compatible laptop so reinstalling ewent perfectly, except these little things.

 I still can’t get in via alt F11. and the options were  different in Word 7. But I had a look around options and developer not ticked. In trust centre my Access to VBA wasn’t ticked. So once i did all this I found developer in my ribbon. I was able to get to all the setting. 

Anther problem I hadprior to this  was my pictures in my files were reverting to 96 dpi and I found a setting to stop this although the highest dpi is under the 300 I want. Never knew such an option existed. So that was a bonus.Thought I should pass this on.

Lesson - don’t spill a cup of tea over your laptop

So thank you so much.

Kind regards