How to restore missing Groups - HELP!

Following a messy install of Dropbox on a new computer, I found I could not open my EndNote Library (*panic*)

The “Recover Library” function worked to restore an .enl and a .data file, that I could open, thankfully containing a complete set of references, with all attachments opening properly from within the library (or at least all those that I’ve tried) etc.  However.  ALL MY GROUPS ARE MISSING!!!  And in a library with about 500 references that had been carefully filed, this is a major loss!

I think it must be some kind of problem in the restored .data folder, or for some reason the EN Program isn’t reading the information in that folder relating to groups.  However I can’t see any clear problem in it.  All the sub-folders in the restored .data folder seem to be there - the restored .rdb folder seems, at a quick glance to contain all the information in the old folder.

Any suggestions as to how to get my groups back up would be very much appreciated.

This has happenend to me once before about a year ago after I had to restore a library.  I somehow made the groups come back but I’m not sure what I did.  This gives me hope however, that there is trick to getting them to come back.


ps.  I have a Time Machine for my Mac at home, which will contain old versions of the files.  I am going to see if I can make the groups work using the old files.  However based on my last experience, I suspect that EN will also not be able to “see” the group info in my old files.

My personal feeling about this problem is that it is a problem in the EN program not “reading” or accessing the groups information properly, rather than the information being missing from the folders.