Missing Groups

My groups are missing and I’d like them back. Note that I did *not* change the name of my library. (I am aware of the importance of renaming the .data file.)

I was snooping around in a historical copy of my rdb folder and noticed that there are four MySQL files that change when I create a new group:

  • jterms.MYI

  • misc.MYD

  • misc.MYI

  • terms.MYI

Deleting allows me to open a copy of my EndNote Library while including them again gives me the error, “EndNote Library could not be opened.”

Even if I could see what was in one group, I would be happy to recreate it.

Any ideas?


EndNote trainer, Weill Cornelll

I used “tools > recover library” and that recovered my groups, so problem solved.

I have the same problem but restoring my library didn’t work. Gah!

And you are also aware that the .DATA folder is “the” essential component of the library and can’t be left behind when moving or renaming a library?  (in edit- see you are also posting a new thread and you do know the .DATA folder’s importance.)

It seems there are other who have troubles with missing groups after recovering a library. But I can’t really follow the advises already given.

I had to recover my library, that created a new .enl-file and a new .data-folder. I updated the list. But the groups were gone!

I tried to copy the old files (misc.frm, misc.myd and misc.myi and misc.tmd) to the new folder, because I thougt that were the files with group data, but it did’t work.

Somebody can help (I use Endnote X3)

Do you still have the original DATA folder and its contents somewhere, uncorrupted?  If so in the same foler as the .DATA folder (not IN the DATA folder) create a text only, blank file (using Notepad or some similar simple text program) with the exact same name as the DATA folder, with the extension .enl.  Open that file and if the DATA folder has what it needs, it shoudl recreate your library with the groups intact. 

I would have thought that is what the recover library command does, but other users have reported success with this approach, when the recover library didn’t work.