Import command doesn't work (to combine two libraries)

I have ENDNOTE X4 in two computers (work and home).

I have tried to combine my libraries, but when I use “Import-file” with the option “EndNote library” . The EndNote program does nothing.

Please help

How are you transferring the library from one computer to other?  Are you bringing the file and the associated .DATA folder (best by compressing the library to an .enlx file from the file>compress menu option and then unpacking, which is achieved by opening the .enlx file in its new home)?  The .enl file alone does not have all the information needed.  Ensure the two libraries don’t have the exact same name, if they reside in the same folder - although that triggers a warning too.  ! 

In a test, I see I get an error message if I try to import a enl file without the associated .DATA folder, but I get no error message if I try to import an .enlx without unpacking it.  Perhaps that is your problem?  Would be nice if that triggered and error message too. 

I assume you have tried opening both libraries individually and they work?