In text citation automatically removes the year


For some reason, when I use APA format, my in-text citation automatically removes the year instead of using the default format. Does anyone know how to modify this?


Please, describe your problem in more detail, and specify whether your are working on Mac or in Windows, which word processor (and which version) and which version of Endnote you are using. 


I am using a Mac with Word 14.2.3 (2010) and EndNote X7.

The problem was that when I would click on “Insert citation”, EndNote would automatically format the citation in the text removing the year e.g. (Brown) instead of (Brown, 2012) and I would have to change manually for each citation from the “Edit citation” from “Exclude year” to “Default format”, but it would always automatically get back to “Exclude year” for every document.

Now, I tried again yesterday modifying the settings and I am facing a new problem:

when I click on “Insert citation”, the temporary citation, e.g. [Brown 2012], stays in the final version of the in-text citation, giving this kind of result:

[Brown 2012(Brown, Kiely, Bharel, & Mitchell, 2012)]

What if you use a different Author, Year output style?  Did you change your “temporary delimiter” to square brackets or make other changes to the temporary citation settings in preferences?  A temporary fix to the original problem would be to turn off the temporary citation settings in the preferences of endnote (edit>preferences>Formatting) to not select the “omit Author and/or Year from  formatted citation if removed from temporary citation”.