CWYW - leaving off Year in in-text citation instead of default format

I have a Mac (Big Sur) and am using Endnote 20 CWYW with Word. I’m using {} brackets for my in-text citations while I write and when Endnote inserts these in-text citations, it will only put (Author) and not use the default format of (Author Year). I have hundreds of citations and don’t want to have to go through every in-text citation one by one to update it to (Author Year). Does anyone have a solution for this problem? 

So you were just typing {author} as you wrote rather than using the copy paste insert citations? 

If so, I don’t have Endnote20, but if you look in preferences, do they still have an option shown in the attachment under “formatting”?  If so, and you remove the checkmark from “omit” it should return them all to an (Author, Year) format.  Can you believe that the developers created this preference option for me, long long ago, when my temporary citations looked like yours, when CWYW was just being introduced!  

If it works, and to do this permanently (if you did ever want to use just the author or just the year but since I never do that, I don’t have a need to do this extra step), you can create a new simple output file that converts the temporary citations to square bracket [author, year] (with square brackets) and the author citation setting as just one author, no et al or anything.  then you can search and replace (with formatting OFF) the square brackets for curly brackets, and switch to your original output style,  turn back on formatting - and they are all fixed!