Journal abbreviations with periods

I am having trouble getting periods to appear in the journal abbreviations.  For instance, I have loaded the output style from the journal Langmuir.  The default setting for journal name was “Don’t replace”, which I switched to “Abbreviation 1”.  This correctly abbreviated all the journal names, but did not add periods.  The “Remove periods” box is not clicked.  The “Abbreviation 2” and “Abbreviation 3” options kept the full journal name.  Is there some way I can add the periods in without doing it manually in the terms list?  Thank you.