Just updated to X7 and syncing shows "a reference with guid does not exist"

When I try and sync the endnote desktop with endnote web, I now get this error?

“a reference with guid does not exist” with an ok box to click.

The desktop and web libraries don’t sync,  any ideas on how to fix this?

I got the same problem when I updated to X7, have you figured out to fix it?


This means a group was renamed, so EndNote lost track of it. To correct it, open EndNote desktop and drag any groups from underneath “Unfiled groups” to “My groups.” Then, sync again.

I may have a related problem:

I have just upgraded to v7 due to upgrading to OSX Mavericks & like everyone else found my v5 was disabled.

I thought I would back up to Endnote Online. Unfortunately virtually all refs in “My Groups” got sucked into an unfiled category. In v5 you could choose which direction had precedence (Mac to Web, or Web to Mac). This doesn’t seem to be an option in v7.

The result is that I wonder whether I have to try and recreate all My Groups on the Web. (Seems unduly tedious & unnecessary?) I suspect that all the refs I had on the web in a ‘general’ - or ‘unfiled’  - category but later put into groups on the desktop were the ones that were ‘sucked out’ leaving only those I had sourced and grouped on the desktop - ie new refs - or at least refs new and unrecognised to the Online Version.

However, when just trying to put all my refs back in the appropriate groups on my desktop, I didn’t realise that syncing could happen automatically & as fast as I re-filed them, they were being sucked back out again. 

I have at least stopped auto syncing till I can get help to sort this out. Anybody know what I can do to nail them back into their appropriate groups, please?

Thanks Gillian, I tried your suggestion, but I still get the error message when I try to sync the library. Any other suggestions?

Hm, sounds like you’ll need to contact our Technical Support for live troubleshooting. http://endnote.com/support/contact-support

I’m sorry to hear you’re still having trouble!

And here’s what finally solved the problem:

I created a new empty library in the desktop version and synced it with Endnote Web, and the error message stopped appearing.

I got this idea from the Norwegian distributor who suggested that my current library could have become corrupt, any idea why this happens?

I did this and EndNote just crashes…Also, the problem with that is that I have more references in my EndNote desktop than in my EndNote Web, i.e…, the desktop is updated while the could is not…

Thanks Jorunn for the advice! I finally got i right and I have had problems with the sync for several weeks with references being duplicated or splitted at syncing. I have no idea why my older files were corrupt, but obviously they were.

I have the same issue…on MacBook.

3 weeks of issues and now this after I was advised to do a fresh sync ‘a reference with Guid does not exist’, and it stops syncing.

Have tried moving unfiled groups to my groups (no change to error note); new library continues to have same error.

Have tried support but getting nowhere.

Not happy, in middle of thesis… Any more suggestions would be welcome. Thanks. 

I am having the same problem. I don’t have any groups under unfiled, and I don’t want to delete my local library and then lose all of the PDFs I have annotated. Please advise how to resolve this without losing all of my PDFs.

Hi - did you get a response to this - the same thing has just happened to me - just coming the end of my thesis so this is a nightmare scenario