Library groups sidebar still doesn't scroll properly (X4)

The first thing I checked when I tested X4 via the trial was whether the groups sidebar scrolls properly when using the wheel on my mouse.  Amazingly, it still doesn’t work…?  This seems like such an obvious, straightforward thing to fix.

Hello - I was unable to reproduce this with EndNote X4. If the left pane has the focus, I am able to scroll with my mouse wheel through the groups. Can you provide more specifics about the type of mouse you are using and your OS?

Best regards,

 - Mathilda, the EndNote team

Thanks for replying!   I’m using Windows XP with the Microsoft Wireless Laser Mouse 5000.

I should add that when I scroll with the mouse wheel, the window pane does move, but only a couple of lines and then stops.  For instance, if I start at the top of the window and scroll down using the wheel on my mouse, the “All References” and “Unfiled” groups will scroll past the screen, but that is the furthest it goes before stopping.  I believe I have the same issue at home (Windows 7 64-bit) with my Logitech mouse (don’t recall model), but I’ll have to check again.

I am not sure of the best way to explain this, but I find that if the endnote library window is not maximized to the external endnote window, the scrolling doesn’t work properly, if the library window is “longer” than the visual space of the program window, no scrolling occurs on the left bar.  On the library side, it doesn’t  seem as persnickety, because there are usually so many that they are beyond the end of the window, and scrolling seems to work, until you get to the end of the invisible list.    

So I have attached two gifs and on the first (wontscroll) the left panel doesn’t appear to scroll but in the willscroll where the endnote window is maximized so it fits into the program window, it will scroll.  

Does this explain the phenomenon you are seeing? If fact, if I choose the third group, with only 15 records in the non-maximized view, the library won’t scroll either.  

I think a few different things may be getting confused here. Leanne’s “wontscroll.gif” shows a state where there is no scroll bar in the EndNote My Library/ Groups pane - so it should not scroll with a mouse wheel or any other way. This is the same behavior one will see in a web browser or Microsoft Word or Outlook.

As for the specific issue with a certain model of wireless mouse, there may be something we need to set in EndNote to improve the interaction but this has never previously been reported so we have not spent time looking into it. We are using very standard Microsoft controls for this window so they should be working as they are intended to. In all of our tests - and in reports from many beta testers - there have not been any problems with mouse wheels and scroll bars in the EndNote library window.

Some other screen shots and specific steps could potentially help. Feel free to send these to me directly.

jason.rollins [@]

Thank you for your follow-up Leanne, but Jason is right.  I have my library window maximized and the scroll bar is showing.  It just doesn’t scroll past one or two lines when I use the wheel on my mouse. 

I found the Microsoft Intellipoint setting that prevented the groups sidebar from scrolling properly.  The setting is called “Enable accelerated scrolling.”  It is on the “Scrolling” tab when you open the mouse properties application in the Windows Control Panel.

1 Like