MAC OSX Endnote X7 in word: A COM exception has occurred, Cannot copy content between these two ranges.

Hi I have an error with endnote help resolving citation with bibliography. It’s a little complicated in my case as i think so.

First some information about the tools I’m using:

 MAC OS X 10.9.4 (13E28)

 Word For MAC 2011, Version 14.4.2

 EndNote X7.0.1 (Bld 9257)

OK. I finished my thesis writing while relying on endnote to help insert citations. The output style I’m using is a one I modified to have multiple sections of reference within the thesis. The citation numbers will start from 1 in every section of the thesis. I attached the styles here. 

In the beginning everything is working well. In the middle I even used the “update citation and bibliography” several times, ok. However, I think I did something not smart or lazy. In the main context, I copied the citation number from one place to another place just for easy. I didn’t insert the citationi at the new place from endnote. After I’ve done the thesis, Just remembered to refresh the citations and bibliography.

Now the update couldn’t finish with error like: “A COM exception has occurred, Cannot copy content between these two ranges.” I have no idea where this error happen since there are hundreds of citations hidden in over 100 pages. Not sure if it’s the style issue or my copy issue.

Please help me as I need get this citation done to submit my thesiss. 
Energy Environ Science_multiple Reference.ens (11 KB)

Do all of this on a copy, so you still have the original.  

Can you format it with a different style?  – that shows where your citations are?  

Did you put the citation INTO a formatted citation?  That can corrupt the field.  

Can you unformat it to temporary citations? (convert to unformated citations) 

Make sure you didn’t insert anything into a bibliography – if a bibliography doesn’t disappear when you convert to temporary citations, that is probably the corruption, which may have nothing to do with your insertion.  

If so the mistake might remain as a supposedly formated citation and be easily spotted.  Especially if you “show fields” in word (shift F9) – don’t worry repeating the command hides them all again!  

If you can’t see anything, can you format them again?  

If you can’t, go back to the unfomated version with the temporary citations and try select all and “convert to plain text” .  Then try formating them again.  This should remove any corrupted hidden fields.  

Go and look at the area where you think you did the insertion which may have corrupted a inserted citation, to see if any funny business is still there.  delete the whole line including the citation and retype it and reinsert the citations.  

Hi Leanne, 

Thanks for your response. I tried your advices: 

I’ve found there are several funny stuff after the citation numbers after I unformatted the citatioin. like  Error! Bookmark not defined  after I try to format the citation. However, there are still error with updating, the error is similar to before. I changed this multiple section of bibliograph back to one section of bibliography. Boom, no errors and the citaion numbers are aligned well with the bibliography. I will just use one setion then.

However, there’s still one issue. The citation number doesn’t start inorder from the beginning of the insertion place. Instead, the citation number 1 was some place in the middle. Do you know how I can reform this to inorder one. I tried updating, doesn’t work.

Thanks again for your help,

1 Like

Is that first citation in a text box?  A figure legend for example?