Multiple in-text citations need to display as [1],[2] or [1]-[3]

Hi A customer has asked me about an IEEE Power Systems Engineering style (customer may be using the basic IEEE style) where the publication his group is writing for requires in text citations to appear as [1],[2] or [1]-[3]. The style as is is displaying [1,2] or [1-3]. There’s an IEEE Power Systems Engineering Letters style that I tried and I found that by editing the separator from , to ],[I could get the [1],[2] citations to work, however, I don’t know how to address the [1-3] situation. Does anyone know of a style that displays multiple in-text citations with brackets like this or how to edit a style to do this or even if this cannot be done in EndNote (and maybe a recommendation for how to resolve–like remove field codes before publication and edit then)? Have a nice day John Paul Fullerton

I don’t think you can achieve what you want automatically.  I think you have achieved the closest option and will need to edit the final copy. 

ON A COPY - To remove “endnote links” you should either use the end note button “remove codes” (which forces you to create a new document) or ctrl A (select all) shift+Ctrl+F9, which will unlink ALL fields.  then you can edit the document for those references that were 3 or more consecutive numbers.

Alternatively, advise your client not to use more than 2 consecutive references in any one place ! :stuck_out_tongue:

I need to display ranges for greater than 2 citations (e.g. 1-3), but commas for 2 citations (e.g. 1,2).

One of my output styles does this, but I cannot seem to edit another one (it does 1-2 instead of 1,2). I cannot find a difference in the settings which I can change to make them both use 1,2 for a range of less then 3. Can anybody help?

Did you try unformating and reformating the manuscript (re-enabling CWYW from the third tab) with your chosen style?  I can’t really figure out a way to force 1-2.  If unformating/reformating doesn’t work, please  attach your style to a reply.  Also tell us what version of Endnote, word processor and operating system you are using. 

I have tried reformating, even tried starting a new manuscript. Attached is my output style. I am using EndNote X3 with Microsoft Word 2007 with windows XP.

ACS Copy.ens (20.3 KB)

yep, no obvious reason, but the ACS style seems to have a bug.  The only thing I could do to fix it, was to create a new output style file and copy everything over to it, exactly as it was in your copy.  The attached works while the “for all intents and purposes” the same exact settings in the original doesn’t.  I suspect the style was amended when there was a numbered style bug and that the underlying code still has an error in it.  I also noticed that while I too had an older ACS output style that has the same bug, the web available versions of ACS styles work producing the 1,2 output (there is no “plain” ACS version though).

ACS-from-scratch.ens (20.9 KB)


Leanne is correct the styles posted on the web should no longer have the error.  

The main ACS style is located at:

The ACS style that does not include a Title field is located at:

Cheryl - The EndNote Team

Thanks you so much Leanne, you have solved my problem