'New Reference' problem with X7.2

I am very grateful that the old search behavior (Search Whole Library for successive searches), but a new problem has arisen:

There is no response to the first search demand: that is, I enter a search enquiry and hit ‘enter’ on my keyboard or ‘search’ on the Endnote search page, and nothing happens. I repeat ‘enter’ or ‘search’, and the search is successfully completed. But now the “New Reference” icon on the toolbar is greyed out and unavailable; Endnote must be closed and re-opened in order to enter a new reference. Control+N does not work while the icon is greyed out; ‘New Reference’ is also greyed out on the "references’ menu.

Can you please attach a screenshot of your full EndNote library screen as it displays right before you do the first search?

I don’t see the symptom of your  problem with perfoming a search in endnote7.2 on Windows 7. 

If you are in the online search mode, you won’t be able to add a new reference unless you return to the library itself?  – and if you are in the library+online, you need to click back into the all references off the database you were searching to add a new reference to the library.  

I am also using Windows 7. The attached screenshot EN1 shows the top of the screen immediately before hitting ‘search’ for the first time; as there is no response, the screen looks the same after this first attempt. Screenshot EN2 shows the same area after hitting ‘search’ a second time, with the greyed out ‘new reference’ icon. I am searching a local library (the same result occurs with any of several local libraries; if two libraries are open, the icon is greyed out in both after a search)

PS: I have also established in the meantime that the ‘new reference’ icon can be restored to active by selecting ‘Show all references’ after a search. This is particularly inconvenient, however, if I want to copy one of the search results in order to paste it into the same library as the basis for a new reference (if I ‘copy’ a reference after a search, ‘paste’ is greyed out in the right-click context menu).

Thanks for reporting this and for the screenshots. I have confirmed the behavior and will enter a bug report.

Note: I was unable to reproduce the reported problem with Search not working the first time. If this is still an issue, please send specific steps and screenshots to me in a private message.

I still have no problem hitting return and getting the results, first click or return.

True, you do need to click into all refs or another a conventional group (clicking in a smart group also greys out the new reference option.  I can only assume that this is because you can’t add a new reference to the search results temp group or to the smart groups which also depend on search parameters. If you click in a conventional group you can add a new reference and when you add that new reference, it also appears in that group.  Not sure if this is on purpose, but that is how it works and would explain why it isn’t available in the other locations.  

(fyi I am another user, and not associated with TR)

Thanks for your comments, Leanne!

Note that Paul prefers to use EndNote’s screen real estate a little differently and does not display the Groups pane, so it took some sleuthing for him to figure out what was going on. The ability to add a new reference in the Search Results group was introduced with the X7.2 release; prior to this (and also in X6) the functionality to add a new reference to Search Results was available. 

Smart Groups function entirely different from the temporary Search Results group. While Smart Groups are also a type of group, EndNote automatically updates these and thus it is not appropriate for the New Reference icon to be available there.

PM sent, thanks.

The “search not executing the first time” issue happens only when the Groups pane is hidden. I know you do not wish to display this pane, but as a workaround you can choose to display it then slide it all the way over to the left margin so only a pixel or two shows. A bug report has been submitted.

OK: I know having a sliver of the "Groups’’ panel is only a minor irritant, but it is still an irritant. I do use groups when collecting related references for a specific purpose, but generally I want to use the full width of my window for my references and the fields that I find useful. Thanks for looking into it, and I look forward to a permanent solution to this strange quirk.

I am very pleased that this glitch (first search does not elicit a response if Groups pane is closed) is solved, but had hoped that the more important ‘new reference’ problem might also have been eliminated. For example, if I wish to duplicate a reference identified by a search (so that I can use it as the basis for a new reference), I need to call up “All references” in order to paste the new reference – and then perhaps reat the same search if I need the results again. I understand that this behavior is caused by X7 treating the search results as a ‘group’,  but this inconvenient feature did not occur in earlier versions of Endnote. Thanks.

Is a fix for this problem envisaged for the near future? In the meantime I have discovered that several colleagues are annoyed by the issue (most, however, thought that they needed to re-start Endnote, rather than just selecting “Show All References” to be able to insert a new reference or even add a copied reference). This problem is not solved by having the ‘Groups’ panel open.