import doesn't work under Mac OS10.5.6

I recently got a new computer running Mac OS10.5.6, and now with Endnote 8, I can no longer import references from text files.  I also cannot import them from PubMed, connecting through Endnote.  This worked fine on my old G4 iMac.  I tried reinstalling Endnote, but this did not help.  Does anyone know how to fix this?  It’s a real drag having to enter all new references by hand!

see where it says:

EndNote 9

Due to major compatibility issues, it is not recommend to run EndNote 9 or earlier on OS X 10.5.

It is not possible to use the “Connect” option reliably.

EndNote 9 will not import text files formatted in many standard direct export formats.

There are no workarounds for these issues.

EndNote 9 and earlier versions will not be updated for Leopard compatibility.

To work with EndNote and Leopard, contact Sales for an upgrade to the current version of EndNote.

EndNote 8 and earlier

EndNote versions prior to version 9 were no longer supported at the time of the OS X 10.5 release. Our current list of supported versions is here.

We will not test or support running these older versions with OS X 10.5.

Note that the issues reported above for EndNote 9 may affect older versions of EndNote as well.