problem updating references

Hi folks. I’ve been adding some DOI numbers to certain records and then trying to check them with the “Find Reference Updates” feature. However, the records that are being suggested by way of updating seem to have nothing to do with the original record!  For example, DOI 10.1021/es070763n is an article titled “Chiral Source Apportionment Of Polychlorinated Biphenyls To The Hudson River Estuary Atmosphere And Food Web” form 2007, but the reference updates feature is matching it with a 1975 article titled “LYSYL oxidase dependent synthesis of a collagen cross-link containing histidine.”  Any idea what’s going on here, or how to fix?  Thank you!

I don’t know, as I put in just the DOI and it updated the rest of the fields just fine?  (Endnote X8 on Windows) see attached.  

Well, unfortunately, this is what I seem to get… I right-click on the entry of interest, select “Find reference updates” and get this result.

Very strange.  I even tried exactly mimicking your fields and removing the ISSN numbers, etc.  Still worked for me.  

I don’t know if the update relies on the same search options as Find Full text, but make sure all the options are selected there in preferences.  

 Is this the only one that does does that - or is it more widespread.  Are you using the most up -to-date version of X7 (X7.7.1 I think)  as I know pubmed changed see:  –  It looks like the X7 logo rather than my X8 logo.  

Finally, in searching Crossref and Endnote – I found this and a couple other sites that suggest you may need to download a new crossref connection file. In my X8 folders I have a crossref.enz and crossref Copy.enz connection file.  Maybe it uses it even though I don’t see or have it selected?   It is my understanding that the doi match is made by crossref.  

If this continues, I suggest you contact tech support as we are a self help customer forum for the most part and you may get faster answers from the help people at Clarivate Analytics?