Updating reference not working


I used to put only the DOI on my reference, close the window, and then press “Find reference updates”. It would then propose me to update all fields found online. 

However, this is not working anymore. I even tried to re-add a previously added article through this method, in order to make sure that it was not a problem with the DOI, but it won’t work.

I tried to reset my preferences as mentionned on another topic, but it didn’t solve the problem. 

MacOS Sierra 10.12.3, EndNote X7 (7.7.1).

Many thanks for helping me out !


1 Like

Same problem here on Endnote X8 (Bld 12000) and Mac OS 10.12.3. 

1 Like

The Find Reference Update command use the CrossRef connection and there is a new version of that file available on our website.

I would try downloading that file using the steps from our website:


You can the try using the Find Reference Update command again.


I have a similar porblem. I enter the DOI link (all other fields remain empty) and the find reference update process says All selected referenec are up to date. The DOI works for sure, it is from the Elsevier database.

I have updated the Crossref connection file as you suggested.

Thank you in advance

updated link to the knowledgebase article (from Mar 2017) is 


But I suspect that CrossRef changed something else, or the appropriate connection file was no longer being used in current versions of X8 and X9?  My CrossRef connection noted in the above,  was  already the version dated Mar 2017.   

When running the find reference updates, I am getting an error message that makes little sense (see attached) – and it comes up even when the DOI field is complete.  If I retrieve the record from pubmed, it seems to work fine, so I am not sure what is breaking the “find updates” piece of the software.  


If I try searching directly the CrossRef database from Endnote it does not work either, however, if I search it online it works. So it is clear a problem with the CrossRef connection file. But as I have read on this forum, for some people even the CrossRef search is working…

I have added the serch result both from the CrossRef webpage and the CrossRef connection from Endnote X9

I am having the same problem with X9 on my mac running MacOS 10.14.2. I’ve tried using the customizer to reinstall the connections but nothing seems to get the “Find Updates” to work properly. Any advice would be much appreciated…it’s a major hassle at the moment.

I’ve been having this same problem using X9 on my macbook running 10.14.2. for the past month or so. I’ve tried resetting the connections using the customizer but this doesn’t seem to help at all. Hopefully a fix is coming soon…it is a major hassle.