Problem with Edit Citation in Endnote X2

I am using Word 2007 with Endnote X2. The edit citation options doesnot appera in the right click menu. Any Possible solutions…suggestions… Thanks Dr. Anil Sukumaran

I’m using X2.0.1 and Office 2003, and as you can see in the attached picture it is working for me. Please note the following:

  • “More” opens the traditional “Edit Citation” window.

  • “Exclude Author/Date” is not available if you use a numbered style.

  • The other “Edit Citation” doesn’t work because it is probably a hangover from X1.

Unfortunately, we do not have Word 2007 available so I can not test this here.

Bes wishes

Jan Ove


1 Like

I’m not sure about it. But I think I’ve encountered same problem when I just installed Endnote. I can’t remember very well. All I remember was there was problem with Add-Ins. If you use Office 2007. That might be the source of problem. Then if you go to word options (it’s somewhere when you hit the office button, I’m very sorry I’m not familiar with Office 2007) you will find Add-ins in the right column. When you hit that, you’ll see manage add-ins in the bottom of new window. Find word add-ins and hit button go. You’ll see all add-ins there and if you check everything related to Endnote, that should solve problem. I think it was the solution. If not, I’m sorry.


If you turn off “check spelling” and “check grammar” or, just  accept / correct spelling and grammar errors first then the Edit Citation right-click menu should appear as expected in Word 2007. It is our understanding that this is a Word limitation/bug and not specifically an EndNote problem.

Jason Rollins, the EndNote team

Hi Jason,

Thanks for your reply. Tried doing as is suggested in the post you directed me to. Still no luck! Is there anything else I can do? Thanks.

Hi Anar,

Thank you very much for trying to help. I tried this, but still no luck. After I tried this, I uninstalled the program, cleaning all its traces, including registry. I then installed the program again, but still I don’t have the option. Thanks