Pubmed search by author - new bug?

I upgraded to endnote 21.3 Build 20232. Since then I advent been able to search articles by author when including a first initial. Previously I could search last name, initial (e.g. Smith, J.) but it now returns no results unless I just search last name (e.g. smith). This is unruly when looking for article by author and year. It previously worked prior to the upgrade so I’m not certain why it changed.

In which operating system? I just tired numerous searches. If the record has initials and no periods, I had no problems, but if the record has full first names and you include a full stop in your search, it didn’t find that record. I did find it without putting in a full stop. Try doing the search without a full stop following the initial.

If that still doesn’t work, I am using 21.3 build 17918, so maybe the windows version works and you are using a Mac version, or perhaps there are different builds (which I doubt).

Hi. I’m on Mac osx. It worked in previous versions but has stopped working on the current build. Perhaps it’s an issue between builds?

Previously I could search by last name, last name one initial (smith, j) and two initial le (smith, j. G.)

I would report the issue (bug) to Support in that case.

Looks like a bug indeed. E.g. a pubmed author search for “smith, j e” gets thousands of hits on Windows (version 21.3 build 17918), but nothing on macOS (version 21.3 build 20232).

I have a similar issue with doi searchers on endnote 21.3 on a mac. PMID ID works, but does not work if there is a space in front of the number (which appears to be automatically inserted if you copy the PMID from the PubMed website). A bit annoying. This started with the last update, so I tend to blame it on Endnote rather than PubMed.
Would be great to have a fix around that sooner than later.

1 Like

Support were already aware of the bug when I reported it.

I am encountering the same problem: author search in PubMed only works when entering the family name. (I am using EndNote 21.3 on a mac.) - Previously it worked as described above (“Smith, J.” )