Same EnNote Library; in OpenOffice a new reference list...


Yesterday I worked on my article, with a lot of references in my EndNote library and even so in my article. Today, I continued working on it, with new references. I entered these references in the same EndNote library.

When I wanted to insert these new references in the same article (in Open Office / Word), my ‘old’ reference list (on the bottom of the text) disappeared an the new references were inserted as a new reference list. The numbering wasn’t correct either, since Word thought it was a new reference list…

Does anyone get my problem, and could you help me?

Thanks in advance.

> Dear Thomson Reuters staffs,

This could be a bug with CWYW for OpenOffice Writer.

My PCs are XP Pro SP3 and Ooo Writer 3.1, and Word 2003, EN X3.0.1 are installed. Jessicaparis’s PC may have Win 7 and only Ooo Writer (I’m not 100% sure).

My problem is reproducible at least when I do the followings.

I type several paragraphs with a few references in Ooo Writer new document, and CWYW formats bibliography just fine. When I keep writing following the last paragraph and insert some references above the first line of the bibliography, it doesn’t insert the references at all. Instead, it deletes the whole section I typed after the last paragraph. When I try “Insert selected citation” button from CWYW tool bar, at the place just above the bibliography list, I get an error message, “Please move the insertion point outside the reference list”. My cursor is not inside the reference list. It is just above that. So, this is very strange.

When I unformat the document, and insert references at the same place (just above the bibliography list), the same thing happens.

I believe there is a bug when CWYW insert/unformat the document, and the cursor is just above the bibliography list.

I’ll check with Win Vista Ultimate 64bit later tonight, and collect additional information. If reproducible with three PCs I can test, I will also e-mail to Tech support as well.

Thank you.

Yes, you are right. I have Windows 7 and EndNote X3. Only OpenOffice 3.1 is registred on my (very new) computer.

I have used previous EndNote versions on my old computer (with Word), and never I have had this problem.

But in fact, you don’t have exactly the same problem as I have, since I don’t get an error message when I’ve insert a new citation with CWYW. This new citation is now again noted as [1], while I have already a citation [1] (which I created yesterday).

And moreover, my old citation list is removed from my article and instead there is this new citation list with my references of today (while it is still the same EndNote library in the EndNote program itsself!).

I hope I have made my problem clear; otherwise I could explain it again and otherwise of course.

Thanks a lot in advance for helping me, because now I couldn’t continue properly with my article…

Yes, I understand our symptoms are different, but my guess is, there are something weird or bugs around CWYW for Ooo Writer. My intention is to draw Thomson Reuters staff’s attention, and look more into it. I have XP and Vista, and you have Win 7, which is great to tell them what is the exact problem for each platform, what are the differences, and so on.

I’ve experienced (or heard) so many CWYW troubles every time either Word or Endnote upgraded. Ooo writer seems like taking the same path, but I’m really serious about abondoning MS office, and try to switch over to Ooo. To invite my colleagues to switch, I want to say “Ooo and Endnote work really well.” but I can’t say that with this problem for now.

In the meantime, if you could, just focus on writing, and I suggest to use RTF file formatting, because the basic RTF formatting (without using CWYW) seems like working fine. A lot of people actually say “I can’t write because CWYW doesn’t work” but I don’t think so. You can (or should be able to) write.


Yes of course you are right; actually I’m writing and editing just the name of the authors or something like that, but I cannot finish my article properly.

But you mentionned to use the RTF file formatting; would you like to explain how to use it (because I have always used EndNote CWYW, which worked really well untill now)?

Thanks a lot for your help (or the help to improve Ooo and EndNote in the future).

Are you sure your insertion point is not within the bibliography bookmark? During beta we ran across this problem, and that’s what it turned out to be. If you’re positive this is not the case, can you attach a sample document that shows the behavior?


OK, here you go:

  1. Write whatever, and when it comes to the point where you want citation, go to the Endnote library.

  2. Click on the reference, or multiple references with Ctrl pressed, then Ctrl+C.

  3. Go back to your document, Ctrl+V to insert. You’ll see unformatted citation in curly brackets, like {Smith, 2008 #432} or {Johnson, 2009 #595;Hammerschmidt, 2007 #214}

  4. When you feel like, “I can’t write any more”, then save as RTF (rich text format) format. Word has the option to save with this format. So does the Ooo writer.

  5. Go back to your Endnote library. From Tools menu > Format paper > Format paper…Choose the document.rtf you just made.

  6. Prompt should appear, and you can choose output style. If there are references of “ambiguity” meaning Endnote can’t tell which reference, you need to Look up, but you probably don’t need it if you follow the way I’m telling.

  7. Endnote will create another rtf format file with the output style name appended at the end.

  8. Open the formatted text with your Word or Ooo Writer, and make sure format is correctly done.

This was the way we’ve used Endnote for looong looong time. It’s still rock solid.

FYI: RTF format preserve pagination, margins, fonts (italic, bold, etc) and line spacing, but it does not support tables, embedded figures, etc. As long as manuscript writing, RTF is just fine most of the time. If your document is somewhat like newspaper, flyer, thesis, grant proposal, then RTF is not powerful enough.

@ Thomson Reuters RSBETA staffs,

Thank you so much for immediate attention. I will change the file extension from .odt to .txt so that I can attach here. Please change it back to .odt when you download it. I am not sure my OpenOffice document will contain traveling library, but this is the file I get the “Please move the insert point…” error. And, all the new files I created behaved in the same way.

Unformatted document was also attached, with .txt extension, but it is actually .odt file.

Best regards,

Sample.txt (12.9 KB)
Sample unformatted.txt (11.1 KB)

Hi All,

I got really quick and immediate response from Thomson Reuters staff about the phenomenon I was experiencing, so let me share the things I figured.

OpenOffice Writer uses so called “Bookmark”, and I can view them from View>Navigator>Bookmark. What it shows is something like grayed text in Word, but I click each Endnote bookmark, and it displays where it is located.

When I click the Endnote Bibliography, which is the list of references at the end of the document, the bookmakr actually includes the title and the line above the title. When I have the cursor above the bibliography title, because I am “inside” the endnote bibliography bookmark, I am not able to insert a reference. Even the word/sentences I type in, are all gone after pressing “format” button.

Now, I figured why it happens, but I still have a question. Why the line above the title is still Endnote bookmark? If somebody doesn’t know, this would happen again and again. Say for example, somebody type long long paragraph just above the bibliography title, including many references (by traditional ctrl+c and ctrl+v), and as soon as hitting Format button from CWYW bar, the long long paragraph and references all disappears! Isn’t that frustrating?

I understood why this happened, but I can’t agree how it is made. To avoid this problem, I actually need to hit enter a couple of times always at the end of the text, just to make sure I’m not within the endnote bookmark, which is a very strange command. Don’t you agree? >Dear Thomson Reuters staffs

Best regards,



Would you take a look at your bookmarks from Navigator, just to see where you are inserting new references? It could be due to a similar problem…I guess.

Message Edited by myoshigi on 11-17-2009 07:51 PM


Your story about Bookmarks in Ooo doesn’t work for me. I’ve tried what you have said, but I really think we have different problems. I don’t get an error message at all. Moreover, the sentence before the citation I would like to enter isn’t being erased: the whole citation list I have created the day before yesterday is being erased.


And, when I look at the Bookmarks in Ooo, the old bookmarks are noted as for example “EndNote Citation %252525252525255BLemb”, while the new citation is entered as “EndNote Citation [Lemberg, 2005 # 96]#000000”.

Moreover, the style of my reference (which now consists of only this newly added citation) is really different than before, while I still have selected the ‘Vancouver Annotation’ in EndNote itself…


I really don’t get it.



When I try to do it like you’ve mentioned with .RTF, it doesn’t work neither. Because I get an error message that my text contains items that cannot be saved in an .RTF format. I have to save it as a .ODF extension to save all the things properly. I have no figures in my article (not yet, those will follow later on), but it will be in the form of a scientific article.

If I save it anyway as an .RTF extension; when I go to Endnote > Tools > Format Paper > Format Paper, I cannot find my article at all (which I just saved as a .RTF format, in spite of the error message!).


I’m so sorry for disturbing you with my problems, but I hope someone could help me in order to finish my article with references!



To save .rtf file, your document needs to be unformatted, plain text (with some font/tab/margin formatting).

Are you able to make a simple text with several references, and add more later after saving? If you can, then the problem is around your particular document. If you can’t, there is a problem with the software/OS.

Getting error message with rtf save sounds like you have much more than plain text in your particular document, and you need to troubleshoot from there. Your bookmark for old citation looks strange, so you might want to unformat all of your old citations and re-insert to make them look like normal first, before you add new citations. My bookmaks are all [Author, Year Record #]#0000xxxx format, except the one for the list of reference at the end (endnote).

It is probably the issue you need to call or e-mail tech support directly.

Another suggestion: Trying to make a DTP-like document with a word processor like Word or Ooo Writer is not a good idea. You’ll face a lot of problems here and there anyway. Using word processor for writing and bibliography referencing, and DTP software (like InDesign from Adobe) separately work much better. Word processors don’t have real controls for font kernelin, frame control, text wrap etc.

If Ooo Writer and Draw are the only tools available, stay with simple text and referencing and comeplete text part first. Then, remove field code/bookmark and start adding figures/frames. If you work them in parallel, then you’ll understand what I mean. Although, it requires some ability to work on text and figures separately, with some imagination in your mind.