show bibliography-URLs as hyperlinks in Word?

How can I display a URL as a hyperlink (underlined in blue and clickable) in the bibliography in Word 365 using the template APA 7 (Endnote X8)?

best regards


In word, on the EndNote Ribbon,  Configure Bibliography settings as in attached image.  

If you want links to be created automatically when you have an URL, you can choose the following steps in Word:

  1. Select “Options” from the “File” menu
  2. Then select “Proofing” and click on the “AutoCorrect Options” button
  3. Finally click on the tab “AutoFormat” and check that links are created automatically

Thanks a lot!

My happyness was to early. Your hints solved my problem only partially.

Solved Problems:

  1. Links from short-reference in the text to reference work perfect now.

  2. Short references within the text are now recognizable as links -> they are blue and underlined

  3. Hyperlinks from the bibliography work perfectly too.

  4. Funktonalities 1-3 work in Word-Documents AND in PDF as they should!

B U T [!] there remains one unsolved Problem:

-> hyperlinks in the reference list are not visually recognizable as active links (they are not blue and underlined) 

(screenshot from APA 7th reference book shows how it should look like)

I tried a lot with the style templates in word … It didn’t work.

thanks a lot for your help, perhaps we will finally solve this riddle too!

best regards


Mine does (see attached).

Did you follow erik-arnes1 advice turning on the autocorrect functions to convert URLs to active links? 

Hello Leanne!

Thanks for the screenshot. Thats exactly how I want it to be. I did everything like erik-arnes1 told me to do.

I added 3 screenshots to show the situation:

scr2) autocorrect fuction to convert URLs to active links is on

scr4) word 365 style template for “endnote bibliography” (automatic generated - without changes from me)

scr5) word 365 sytle template for “hyperlinks” (automatic generated by word - wihout changes from me)

I believe, that the cause of the problem is anywhere in the word 365 style templates

hope you  have further  proposals

best regards


Hi Leanne!

I have an idea: can you send me your word-example - as word-document?

I will open it and check your style templates - perhaps I find the difference in the word-settings and can adapt mine -

or - more easily: i can use your document with its settings as template-file for further word documents?

I can try it -> perhaps it works! (perhaps not)

best regards


I could, but I tested. If I turn off the autocorrect option to convert AND updated the bibliography - the blue underlines disappear.  If I turn it back on, AND then update the bibliography, they reappear.  I don’t think my settings in the document will override your setting.  

Because the forum provider won’t allow links that are word documents.  I will attach a version you will have to save it and rename it.  

Nevermind, it doesn’t let me attach it anyway.  – so you should contact me thru the messaging and I can email it to you, if you give me your email address.  I dont’ recommend posting your email address in the forum.   

I believe most of our settings are the same, but can you show me the hyperlink style view?  see  my images.  


Dear Leanne and Erik-arnes1!

I finally found the solution. We were so close. I had to put another check mark in WORD / FiILE / OPTIONS / AUTOCORRECT

the first check mark (which I had already to put) was the one I was told from Erik-arnes1 in the section " AutoFormat": “Internet and network paths with hyperlinks

the second check mark which I found now was in the section " AutoFormat As You Type" - It has the same name: “Internet and network paths with hyperlinks” (screenshot below).

AND -> " Update Citations and Bibliography" in the Endnote Section of Word. (as you told me)

Immediatly the hyperlinks in the Literature-Liste were presented blue and underlined! Exactly how I wanted it to be.

Word 365 can really be tricky too!

Thanks a lot for your efforts and your patience!

With Best Regards


1 Like